diff mbox series

[bug#64483,2/2] gnu: mactelnet: Unbundle uthash.

Message ID 4ba2f134cc5154666c5e5b19710cbd42d9642da8.1688574761.git.mirai@makinata.eu
State New
Headers show
Series gnu: Add mactelnet. | expand

Commit Message

Bruno Victal July 5, 2023, 4:34 p.m. UTC
* gnu/packages/admin.scm (mactelnet)[source]: Unbundle uthash.
[inputs]: Add uthash.
[license]: Remove bsd-2.
---
 gnu/packages/admin.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bbcd364dad..c1bcdb01b4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -114,6 +114,7 @@  (define-module (gnu packages admin)
   #:use-module (gnu packages cryptsetup)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages dns)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages file)
@@ -5866,12 +5867,19 @@  (define-public mactelnet
               (sha256
                (base32
                 "1z63dz22crrvrm0sh2cwpyqb7wqd9m45m6f2641mwmyp6hcpf4k4"))
-              (patches (search-patches "mactelnet-remove-init.patch"))))
+              (patches (search-patches "mactelnet-remove-init.patch"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (delete-file "src/utlist.h")
+                   (substitute* (find-files "src/" "\\.c$")
+                     (("\"utlist\\.h\"") "<utlist.h>"))))))
     (build-system gnu-build-system)
     (arguments
      (list
       #:tests? #f))  ; no tests
     (native-inputs (list autoconf automake gettext-minimal))
+    (inputs (list uthash))
     (synopsis "MAC-Telnet utilities for communicating with RouterOS devices")
     (description "This package provides an implementation of the MAC-Telnet protocol
 used by RouterOS devices.  It provides the following commands:
@@ -5890,6 +5898,4 @@  (define-public mactelnet
      (list license:gpl2+
            ;; Note: applies to src/md5.{c,h}
            ;; This file is likely to be gone in the next release.
-           license:zlib
-           ;; Bundled uthash-1.9.9.
-           license:bsd-2))))
+           license:zlib))))