diff mbox series

[bug#67464,gnome-team,3/4] gnu: Add libei.

Message ID 4b950299eb4f1a5f965912982bfd11d19c3ce898.1701039139.git.vivien@planete-kraus.eu
State New
Headers show
Series Update mutter | expand

Commit Message

Vivien Kraus Nov. 26, 2023, 3:03 p.m. UTC
* gnu/packages/freedesktop.scm (libei): New variable.

Change-Id: I83f5826ca691446194501f75f90c7babcd564f8c
---
 gnu/packages/freedesktop.scm | 40 ++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 25b7998d05..d7fe203728 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -736,6 +736,46 @@  (define-public libinput-minimal
                "-Ddebug-gui=false"    ;requires gtk+@3
                ,flags))))))
 
+(define-public libei
+  (package
+    (name "libei")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/libinput/libei.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "0j1xplvi81h5lmg7qxm7vazh76b3k68vnbpv1iag1b4ps7cmkdkr"))
+              (snippet
+               #~(begin
+                   (use-modules (guix build utils))
+                   (substitute* "test/meson.build"
+                     (("subproject\\('munit'")
+                      "# subproject('munit'")
+                     ((", fallback: \\['munit', 'munit_dep'\\]")
+                      ""))
+                   (delete-file-recursively "subprojects")))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:configure-flags #~'("-Ddocumentation=api" ;protocol requires hugo
+                            "-Dsd-bus-provider=libelogind")))
+    (inputs
+     (list elogind libevdev libxkbcommon))
+    (propagated-inputs
+     ;; liboeffis-1.0.pc requires.private libelogind
+     (list elogind))
+    (native-inputs
+     (list doxygen libxml2 munit pkg-config python python-attrs python-black python-dbusmock python-jinja2 python-pytest python-structlog valgrind/interactive))
+    (home-page "https://libinput.pages.freedesktop.org/libei/")
+    (synopsis "Emulated Input protocol implementation")
+    (description
+     "Libei provides a client and server implementation of the @acronym{EI,Emulated
+Input} protocol for Wayland compositors.")
+    (license license:x11)))
+
 (define-public libxdg-basedir
   (package
     (name "libxdg-basedir")