[bug#77316] gnu: Add python-crc.

Message ID 4b8466278b262926f8bf289bd4dc0df830bfe536.1743091160.git.csantosb@inventati.org
State New
Headers
Series [bug#77316] gnu: Add python-crc. |

Commit Message

Cayetano Santos March 27, 2025, 3:59 p.m. UTC
  * gnu/packages/python-xyz.scm (python-crc): New variable.

Change-Id: I6d9c4320c1e4b01fe4c87013b7ff6761d993bad4
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: eb30f5ecbea896e9cf93722bf97681d208f1a7be
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8c7a60f3e7..81f4b6cead 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16725,6 +16725,30 @@  (define-public python-cram
 output.")
     (license license:gpl2+)))
 
+(define-public python-crc
+  (package
+    (name "python-crc")
+    (version "7.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Nicoretti/crc/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1b9164z6v3ng5s8564a0gjdzqws6zf5aqvk6mnzw7ysk6d5rbb9r"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools python-wheel
+                         ;; tests
+                         python-poetry-core python-pytest))
+    (home-page "https://nicoretti.github.io/crc/")
+    (synopsis "Pure Python CRC library")
+    (description
+     "This library computes and verifies CRC checksums, using predefined and
+custom CRC configurations.")
+    (license license:bsd-2)))
+
 (define-public python-crccheck
   (package
     (name "python-crccheck")