[bug#77555] gnu: minipro: Update to 0.7.2.
Commit Message
* gnu/packages/electronics.scm (minipro): Update to 0.7.2.
Change-Id: I73ee2d3e8e7db9ad5978576816926b2ae163a270
---
Updated and applied style.
gnu/packages/electronics.scm | 49 ++++++++++++++++++------------------
1 file changed, 25 insertions(+), 24 deletions(-)
base-commit: 521d08c6b938c4a4d207250a71966a1f7319202a
--
2.49.0
Comments
Cayetano Santos <csantosb@inventati.org> writes:
> * gnu/packages/electronics.scm (minipro): Update to 0.7.2.
Pushed as commit f658cd1.
> Updated and applied style.
I leave out the style change.
Thank you!
@@ -475,30 +475,28 @@ (define-public m8c
(define-public minipro
;; Information needed to fix Makefile
- (let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")
- (commit-short (substring commit 0 8))
- (date "2022-09-10 21:44:06 -0700"))
+ (let* ((date "2024-09-20 20:55:06 -0700"))
(package
(name "minipro")
- (version "0.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/DavidGriffith/minipro.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03xgmvvsxmqrz7blg7cqk0pb9ynhlq6v6jfl532zmjdzp5p3h10d"))))
+ (version "0.7.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/DavidGriffith/minipro.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a7sbbs1byngkh3bh0dxwxk1iw1dx0kvp946y2lxb8rm6b7hwqym"))))
(native-inputs (list pkg-config which))
(inputs (list libusb))
(build-system gnu-build-system)
(arguments
(list
- #:tests? #f ; no test suite
+ #:tests? #f ;no test suite
#:phases
#~(modify-phases %standard-phases
- (delete 'configure) ; No ./configure script
+ (delete 'configure) ;No ./configure script
(add-before 'build 'fix-makefile
(lambda _
;; Fix some git related variables that minipro expects
@@ -506,17 +504,20 @@ (define-public minipro
(("GIT_BRANCH = .*")
(string-append "GIT_BRANCH = \"master\"\n"))
(("GIT_HASH = .*")
- (string-append "GIT_HASH = \"" #$commit "\"\n"))
- (("GIT_HASH_SHORT = .*")
- (string-append "GIT_HASH_SHORT = \"" #$commit-short "\"\n"))
+ (string-append "GIT_HASH = \""
+ #$version "\"\n"))
(("GIT_DATE = .*")
- (string-append "GIT_DATE = \"" #$date "\"\n"))))))
+ (string-append "GIT_DATE = \""
+ #$date "\"\n"))))))
#:make-flags
- #~(list (string-append "VERSION=" #$version)
- (string-append "PREFIX=" #$output)
- (string-append "UDEV_DIR=" #$output "/lib/udev")
- (string-append "COMPLETIONS_DIR=" #$output
- "/share/bash-completion/completions"))))
+ #~(list (string-append "VERSION="
+ #$version)
+ (string-append "PREFIX="
+ #$output)
+ (string-append "UDEV_DIR="
+ #$output "/lib/udev")
+ (string-append "COMPLETIONS_DIR="
+ #$output "/share/bash-completion/completions"))))
(synopsis "Controls the TL866xx series of chip programmers")
(description
"minipro is designed to program or read the contents of