[bug#76960,1/2] gnu: spdlog: Update to 1.15.1.

Message ID 4afc3dd190b07fc719ba218adfacceb6f7ba1214.1742145224.git.code@greghogan.com
State New
Headers
Series [bug#76960,1/2] gnu: spdlog: Update to 1.15.1. |

Commit Message

Greg Hogan March 16, 2025, 5:14 p.m. UTC
  * gnu/packages/logging.scm (spdlog): Update to 1.15.1.
(spdlog-1.13): New variable.

Change-Id: I2458a03792b967fcf6761aa31b302d041a0abe3e
---
 gnu/packages/logging.scm | 17 +++++++++++++++--
 1 file changed, 15 insertions(+), 2 deletions(-)


base-commit: 8a565a8ff1c2150b778b5fdf8aa3a5f59a3fce9d
  

Patch

diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 9cc28279d7e..b5431566fe4 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -239,7 +239,7 @@  (define-public multitail
 (define-public spdlog
   (package
     (name "spdlog")
-    (version "1.13.0")
+    (version "1.15.1")
     (source
      (origin
        (method git-fetch)
@@ -248,7 +248,7 @@  (define-public spdlog
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))
+        (base32 "1drpbn7b6iikypdlsvzpcjwyls0rqzl7sz7f7xjbn3d7ic55a1p1"))))
     (build-system cmake-build-system)
     ;; TODO run benchmark. Currently not possible, as adding
     ;; (gnu packages benchmark) forms a dependency cycle
@@ -268,6 +268,19 @@  (define-public spdlog
     ;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
     (license (list license:expat license:bsd-2))))
 
+(define-public spdlog-1.13
+  (package/inherit spdlog
+    (version "1.13.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gabime/spdlog")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name (package-name spdlog) version))
+       (sha256
+        (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))))
+
 (define-public spdlog-1.10
   (package
     (inherit spdlog)