diff mbox series

[bug#50389,core-updates-frozen] gnu: libsrtp: Update to 2.4.0.

Message ID 4a755ac9ee4129086c381318daa2ea5249538031.1630807703.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#50389,core-updates-frozen] gnu: libsrtp: Update to 2.4.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Sept. 5, 2021, 2:13 a.m. UTC
Fix building libsrtp with GCC 10 by updating to 2.4.0.

* gnu/packages/telephony.scm (libsrtp): Update to 2.4.0.
---
This fixes the build for libsrtp (and its 35 dependents, if they have no other
issues) by updating to 2.4.0.  I was able to build this on x86_64, but I don't
have the spare cycles to build its dependents.

Its changelog looks okay to me, but here are the changes since the last
version [0]:

--8<---------------cut here---------------start------------->8---
Major changes

#529 - Remove EKT files, this was never completed and the draft has since changed.
#512 - Adds suport for Mbedtls as a crypto backend.
#503 - Support apple silicon build.
#495 - Adds support for the Meson build system. This is an alternative to Cmake and auto tools.

Other changes

#546 - Improve OpenSSL KDF check.
#542 - Add void to function declarations for EVP_EncryptInit check.
#531 - Remove dead code.
#524 - Support running against nss >= 3.52.
#521 - Remove references to dtls from libsrtp.
#520 - Use nss based hmac when nss enabled.
#519 - Move selftest vectors form backends to common files.
#515 - Extend cmake support.
#514 - Fix gcc11 warning by defining output length.
#502 - Remove visual studio build files.
#501 - cmake: Set the VERSION property of the srtp2 library.
#500 - Fixed issue #499 with buffer overflow.
#498 - Feature/additional error checks.
#496 - Rework check for OPENSSL_cleanse().
#492 - Avoid non-existing compiler flag -O4.
#491 - Fix two-byte RTP header extension encryption.
#478 - Modify cmake to install crypto_types.h instead of cipher_types.h
--8<---------------cut here---------------end--------------->8---

[0] https://github.com/cisco/libsrtp/blob/master/CHANGES

--
Sarah

 gnu/packages/telephony.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: 68dd6d809398297dc2ebef522186c9b9f2566739

Comments

Guillaume Le Vaillant Sept. 5, 2021, 9:12 a.m. UTC | #1
Patch pushed as 2302adc0eca384fa5d2a78bbfc13dd596a1e2175.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 9924031993..3035809225 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -413,7 +414,7 @@  internet.")
 (define-public libsrtp
   (package
     (name "libsrtp")
-    (version "2.3.0")
+    (version "2.4.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -422,7 +423,7 @@  internet.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1f7i3jdh1wzdv7zjlz7gs3xw5jqig9zw8z9awsqqcp54f94xdpvd"))))
+                "0syl2ywddgqz29h43d6rc7waf3hp2yc14yhnrvdsja2bg8wrv6sb"))))
     (native-inputs
      `(("psmisc" ,psmisc)               ;some tests require 'killall'
        ("procps" ,procps)))