diff mbox series

[bug#38896] gnu: Add gupnp.

Message ID 4a6ef1146155bb28719ed0d3ad346d6a1422f789.camel@disroot.org
State Accepted
Headers show
Series [bug#38896] gnu: Add gupnp. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 4:07 p.m. UTC
Hello Guix!

Please find the attached patch to add gupnp.

NOTE: This patch depends on patch #38894.

Regards,
RG.

Comments

Raghav Gururajan Jan. 12, 2020, 10:57 p.m. UTC | #1
v2
Raghav Gururajan Jan. 12, 2020, 11:04 p.m. UTC | #2
v3
Danny Milosavljevic Jan. 13, 2020, 7:48 a.m. UTC | #3
Pushed to guix master as commit 291a85b29b166200dcc5bd2ff69af5e13ab68877
after removing network-manager since it didn't change anything in the result.
diff mbox series

Patch

From 2bc19cc86b7dbc7ed1bdf82f9f10a6c0a6611ad3 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 11:03:12 -0500
Subject: [PATCH] gnu: Add gupnp.

* gnu/packages/gnome.scm (gupnp): New variable.
---
 gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b32fc43eec..7d10bb9bac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -275,6 +275,37 @@  and announcement over SSDP.")
    (home-page "https://gitlab.gnome.org/GNOME/gssdp")
    (license license:gpl2)))
 
+(define-public gupnp
+  (package
+   (name "gupnp")
+   (version "1.2.2")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "12cr3isww4zl0d4himpd2fhl2wmy3jh8sbxp4snp51sw7savv04s"))))
+   (build-system meson-build-system)
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("gssdp" ,gssdp)
+      ("gtk-doc" ,gtk-doc)
+      ("gobject-introspection" ,gobject-introspection)
+      ("gtk+" ,gtk+)
+      ("libsoup" ,libsoup)
+      ("network-manager" ,network-manager)
+      ("vala" ,vala)))
+   (synopsis "GUPnP API for GNOME desktop")
+   (description "GUPnP is an object-oriented open source framework for creating
+UPnP devices and control points, written in C using GObject and libsoup.")
+   (home-page "https://gitlab.gnome.org/GNOME/gupnp")
+   (license license:gpl2)))
+
 (define-public libmediaart
   (package
     (name "libmediaart")
-- 
2.24.1