From 2bc19cc86b7dbc7ed1bdf82f9f10a6c0a6611ad3 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 11:03:12 -0500
Subject: [PATCH] gnu: Add gupnp.
* gnu/packages/gnome.scm (gupnp): New variable.
---
gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -275,6 +275,37 @@ and announcement over SSDP.")
(home-page "https://gitlab.gnome.org/GNOME/gssdp")
(license license:gpl2)))
+(define-public gupnp
+ (package
+ (name "gupnp")
+ (version "1.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12cr3isww4zl0d4himpd2fhl2wmy3jh8sbxp4snp51sw7savv04s"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gssdp" ,gssdp)
+ ("gtk-doc" ,gtk-doc)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("libsoup" ,libsoup)
+ ("network-manager" ,network-manager)
+ ("vala" ,vala)))
+ (synopsis "GUPnP API for GNOME desktop")
+ (description "GUPnP is an object-oriented open source framework for creating
+UPnP devices and control points, written in C using GObject and libsoup.")
+ (home-page "https://gitlab.gnome.org/GNOME/gupnp")
+ (license license:gpl2)))
+
(define-public libmediaart
(package
(name "libmediaart")
--
2.24.1