[bug#76334] gnu: Add python-platypush.

Message ID 4a357eae96e8e82b36b48bf12c38a52cc5fff0fa.1739709030.git.mail@pisemsky.site
State New
Headers
Series [bug#76334] gnu: Add python-platypush. |

Commit Message

Evgeny Pisemsky Feb. 16, 2025, 12:30 p.m. UTC
  * gnu/packages/engineering.scm (python-platypush): New variable.

Change-Id: If4719a6c1bc2ee7eb2689a9ada618ec5f86f3f46
---
 gnu/packages/engineering.scm | 60 ++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)


base-commit: dd7a377c38c2a3e0cb80b0e45b32dfbe4577a739
  

Comments

Ludovic Courtès March 10, 2025, 2:33 p.m. UTC | #1
Evgeny Pisemsky <mail@pisemsky.site> skribis:

> * gnu/packages/engineering.scm (python-platypush): New variable.
>
> Change-Id: If4719a6c1bc2ee7eb2689a9ada618ec5f86f3f46

Applied, thanks!
  

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index a5dbe51198..b749fb0e9b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -146,6 +146,7 @@  (define-module (gnu packages engineering)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-compression)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-web)
@@ -1983,6 +1984,65 @@  (define-public python-capstone
     (propagated-inputs
      (list capstone))))
 
+(define-public python-platypush
+  (package
+    (name "python-platypush")
+    (version "1.3.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.platypush.tech/platypush/platypush.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1chd60r4misz2i368435yb6hhnm97v8kncjnchxj8mg3mglw9gy0"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'relax-requirements
+            (lambda _
+              (substitute* "requirements.txt"
+                (("zipp>=3.19.1")
+                 "zipp")
+                (("urllib3>=2.2.2")
+                 "urllib3"))))
+          (add-before 'check 'pre-check
+            (lambda _
+              (setenv "HOME" "/tmp"))))))
+    (native-inputs (list python-setuptools python-wheel python-pytest redis))
+    (propagated-inputs (list python-alembic
+                             python-croniter
+                             python-docutils
+                             python-flask
+                             python-marshmallow
+                             python-pillow
+                             python-pygments
+                             python-pyotp
+                             python-dateutil
+                             python-magic
+                             python-pyyaml
+                             python-pyzbar
+                             python-qrcode
+                             python-redis
+                             python-requests
+                             python-rsa
+                             python-sqlalchemy-2
+                             python-tornado
+                             python-urllib3
+                             python-websocket-client
+                             python-websockets
+                             python-werkzeug
+                             python-zeroconf
+                             python-zipp))
+    (home-page "https://platypush.tech/")
+    (synopsis "General-purpose automation framework")
+    (description
+     "Platypush is a general-purpose and extensible platform for automation across
+multiple services and devices with hundreds of supported integrations.")
+    (license license:expat)))
 
 (define-public python-esptool
   (package