diff mbox series

[bug#72133,2/2] gnu: Add python-pandapipes.

Message ID 4a31aeddd0a9029e9213e6602149060103c108aa.1721091992.git.monego@posteo.net
State New
Headers show
Series Add python-pandapower and python-pandapipes | expand

Commit Message

Vinicius Monego July 16, 2024, 1:10 a.m. UTC
* gnu/packages/engineering.scm (python-pandapipes): New variable.

Change-Id: I5858f8a82ec6b351e14a03ecc52a0b9fef62f7c0
---
 gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

jgart July 16, 2024, 5:36 a.m. UTC | #1
Thanks, applied!
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6e204e6b6d..2875d45330 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2661,6 +2661,31 @@  (define-public python-pandapower
 @code{PowerModels.jl} library.")
     (license license:bsd-3)))
 
+(define-public python-pandapipes
+  (package
+    (name "python-pandapipes")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pandapipes" version ".zip"))
+       (sha256
+        (base32 "06yqqd25hxa6q49qcbpy0njwxkqzfhbff4frrrxd84391njgvdhq"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-nbmake
+                         python-pytest
+                         python-pytest-xdist
+                         unzip))
+    (propagated-inputs (list python-matplotlib
+                             python-pandapower
+                             python-shapely))
+    (home-page "http://www.pandapipes.org")
+    (synopsis "Simulation of multi energy grids")
+    (description
+     "This package provides a pipeflow calculation tool that complements
+@code{pandapower} in the simulation of multi energy grids.")
+    (license license:bsd-3)))
+
 (define-public python-scikit-rf
   (package
     (name "python-scikit-rf")