[bug#78086,v3] gnu: Add emacs-org-rss-publishing.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-org-rss-publishing): New variable.
Change-Id: Ia1b02e050c42b1edcff6ad94a9599c87170e1a12
---
Ooops! I messed things up and sent a v2 which is identical to v1! Here's the new
patch with the various fixes. Hope it's alright. Thanks, cheers, Fabio.
gnu/packages/emacs-xyz.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)
base-commit: 7e5913f90df916d8d9f5c509354d62324f54f481
Comments
>dim. 27 avril 2025 at 19:51, Fabio Natali <me@fabionatali.com> wrote:
> * gnu/packages/emacs-xyz.scm (emacs-org-rss-publishing): New variable.
>
> Change-Id: Ia1b02e050c42b1edcff6ad94a9599c87170e1a12
> ---
> Ooops! I messed things up and sent a v2 which is identical to v1! Here's the new
> patch with the various fixes. Hope it's alright. Thanks, cheers, Fabio.
The let binding was fine, no need to remove it. Have a look at
emacs-0x0, for example, you can use it as a template (adding the
#:tests? flag)
C.
@@ -129,7 +129,7 @@
;;; Copyright © 2023, 2025 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2022-2023 Simon Josefsson <simon@josefsson.org>
-;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
+;;; Copyright © 2023, 2025 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
@@ -31854,6 +31854,31 @@ (define-public emacs-org-web-tools
inserts it as an Org entry instead of displaying it in a new buffer.")
(license license:gpl3+)))
+(define-public emacs-org-rss-publishing
+ (package
+ (name "emacs-org-rss-publishing")
+ (version "0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~taingram/org-publish-rss")
+ (commit "1b33dc252cfedfbb2107ea407266b168b71bebb1")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0axz3r8jw15imhfmbriljsiaxiiqhgrq77nad3kmmgpmvhhlk65f"))))
+ (build-system emacs-build-system)
+ (arguments `(#:tests? #false)) ;no tests
+ (home-page "https://git.sr.ht/~taingram/org-publish-rss")
+ (synopsis "RSS generator for Org Mode's built-in publishing system")
+ (description "This package adds new RSS generation options to the
+@code{org-publish-project-alist} variable (see the Org manual if you are new to
+the publishing options). It adds @code{:auto-rss} and other options that work
+similar to the included @code{:auto-sitemap} functionality. This should make it
+easy for users to add RSS feeds to existing Org-based websites.")
+ (license license:gpl3+)))
+
(define-public emacs-blimp
(let ((commit "e420763d6d18b5d1be552cdbc47f91418343db03"))
(package