diff mbox series

[bug#56654] gnu: Remove chicken-args.

Message ID 4a2c75a1a5968b3f916ca96c4be98e407ae74e67.1658298452.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#56654] gnu: Remove chicken-args. | expand

Checks

Context Check Description
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 20, 2022, 6:27 a.m. UTC
This package requires chicken-srfi-37, which we don't provide since it is
non-free. See https://issues.guix.gnu.org/56295#6.  I missed removing this
package when removing chicken-srfi-37 prior to pushing issue 56295.

* gnu/packages/chicken.scm (chicken-args): Delete variable.
---
 gnu/packages/chicken.scm | 20 --------------------
 1 file changed, 20 deletions(-)


base-commit: d982c00334003b5118ac64929ee696c48f82da60

Comments

Ludovic Courtès Aug. 3, 2022, 3:29 p.m. UTC | #1
Hi,

Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> This package requires chicken-srfi-37, which we don't provide since it is
> non-free. See https://issues.guix.gnu.org/56295#6.  I missed removing this
> package when removing chicken-srfi-37 prior to pushing issue 56295.
>
> * gnu/packages/chicken.scm (chicken-args): Delete variable.

This was done in 5b351982c2a90b72520e992799d012823edfeeb7.

In general, feel empowered to fix obvious errors like this one.  When
doing so, you can clarify in the commit log why you are
reverting/removing things.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 3ae4c7210c..b87b8118f1 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -329,23 +329,3 @@  primitives.  More specifically, provided are:
 @end itemize
 @end itemize")
     (license license:bsd-3)))
-
-(define-public chicken-args
-  (package
-    (name "chicken-args")
-    (version "1.6.2")
-    (source (origin
-              (method url-fetch)
-              (uri (egg-uri "args" version))
-              (sha256
-               (base32
-                "0knkg31d4dq9a8rq9g3ycmj0z6j9l7zp93qa9cnqc8ixd6jsymkm"))))
-    (build-system chicken-build-system)
-    (arguments '(#:egg-name "args"))
-    (propagated-inputs (list chicken-srfi-1 chicken-srfi-13 chicken-srfi-37))
-    (home-page "https://wiki.call-cc.org/egg/args")
-    (synopsis "Command-line argument handling, on top of SRFI 37")
-    (description "This extension provides a wrapper around
-SRFI-37 (args-fold).  The main goal is to let the user parse command-line
-arguments without having to write a lot of similar support code every time.")
-    (license license:bsd-3)))