diff mbox series

[bug#43624] Add emacs-mood-line

Message ID 4GvVAJeTFZKw5WgUEXXxi9kTcCkzvYdnmqSeiesdQvXl9JbUe8CUIQu1u7r4s18KesfVyPdp5fMzAs6ULbRwf53c2j5lsoH7tmTp6lt_4bw=@protonmail.com
State Accepted
Headers show
Series [bug#43624] Add emacs-mood-line | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

kasper.andersson--- via Guix-patches" via Sept. 25, 2020, 6:10 p.m. UTC
Hello, i made a patch to add the mood-line emacs package.
This is my first contribution, let me know if i did something wrong.

Grassi Marco

Comments

Nicolas Goaziou Sept. 27, 2020, 12:24 p.m. UTC | #1
Hello,

"marco.au.grassi98--- via Guix-patches" via <guix-patches@gnu.org>
writes:

> Hello, i made a patch to add the mood-line emacs package.

Thank you.

> This is my first contribution, let me know if i did something wrong.

Welcome!

I made the changes detailed below and applied your patch.

> Subject: [PATCH] Add emacs-mood-line.

I changed the commit message to

    gnu: Add emacs-mood-line.

    * gnu/packages/emacs-xyz.scm (emacs-mood-line): New variable.

as it is standard practice in the repository. If you use Emacs (!) and
Yasnippets, typing "add" and <TAB> in an empty commit message should
fill the template above for you.

> +   (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                  (url "https://gitlab.com/jessieh/mood-line.git")
> +                  (commit version)))
> +            (file-name (git-file-name name version))
> +            (sha256
> +             (base32
> +              "0fh9j9fkgl433nykfzjnzap5labi4sdndfk1nv4f904ij69pmvxb"))))

I moved `origin' below `source' and the hash string on the same line as
`base32'. I also fixed indentation of the whole definition. Eventually,
I removed the ".git" suffix from the URI.

> +   (build-system emacs-build-system)
> +   (home-page "https://gitlab.com/jessieh/mood-line")
> +   (synopsis "Minimal mode-line for Emacs")
> +   (description "Mood-line is a minimal mode-line configuration that aims
> +to replicate some of the features of the
> +doom-modeline package.")

I added a reference to Emacs in the description, moved the text below
the `description' keyword (a nitpick of mine), and changed doom-modeline
to Doom modeline (nitpick about typography vs. Lisp naming practices).

> +   (license license:gpl3+)))

I also added a copyright line for you in the file header. Please let me
know if I fumbled on one of its parts.

I also fixed the license, which is gpl2+ according to library's header
lines.

Regards,
diff mbox series

Patch

From 295667c685d2ab5cf482931290548ef446226ae2 Mon Sep 17 00:00:00 2001
From: AuPath <marco.au.grassi98@protonmail.com>
Date: Fri, 25 Sep 2020 19:52:24 +0200
Subject: [PATCH] Add emacs-mood-line.

---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b75219077..1d1c3957f6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23032,6 +23032,27 @@  icon support, git integration, and several other utilities.")
     (home-page "https://github.com/seagle0128/doom-modeline/")
     (license license:gpl3+)))
 
+(define-public emacs-mood-line
+  (package
+   (name "emacs-mood-line")
+   (version "1.2.4")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://gitlab.com/jessieh/mood-line.git")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "0fh9j9fkgl433nykfzjnzap5labi4sdndfk1nv4f904ij69pmvxb"))))
+   (build-system emacs-build-system)
+   (home-page "https://gitlab.com/jessieh/mood-line")
+   (synopsis "Minimal mode-line for Emacs")
+   (description "Mood-line is a minimal mode-line configuration that aims
+to replicate some of the features of the
+doom-modeline package.")
+   (license license:gpl3+)))
+
 (define-public emacs-shrink-path
   (package
     (name "emacs-shrink-path")
-- 
2.28.0