diff mbox series

[bug#59759] gnu: Add hydra.

Message ID 4GEZ3KkamZ9M6fpskUJyPfs9NtKN7ybX8B6iOl9b-Enwe0Ghg8DpYrFITMJ9G_jNq2jzcXQELvHtWD9TOtGDQNkEVdrc-b3uuLD9klZzLsM=@protonmail.com
State New
Headers show
Series [bug#59759] gnu: Add hydra. | expand

Commit Message

phodina Dec. 2, 2022, 5:13 a.m. UTC
Hi,

here's hydra package for doing parallel login cracking. Please use for legitimate purposes only.

----
Petr

Comments

Ludovic Courtès Jan. 8, 2023, 11:20 a.m. UTC | #1
Hi,

phodina <phodina@protonmail.com> skribis:

> From 34a6f226063c49d326966d01e78092a40177a05f Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 24 Feb 2022 19:29:14 +0100
> Subject: [PATCH] gnu: Add hydra.
>
> * gnu/packages/password-utils.scm (hydra): New variable.

[...]

> +              (uri (string-append
> +                    "https://salsa.debian.org/pkg-security-team/hydra/-/archive/upstream/"
> +                    version "/hydra-upstream-" version ".tar.gz"))

This is a generated tarball.  Please use ‘git-fetch’ instead and make
sure to check ‘guix lint’.

> +    (home-page "https://salsa.debian.org/pkg-security-team/hydra")

According to ‘README’, upstream is actually
<https://github.com/vanhauser-thc/thc-hydra>, no?

> +    (synopsis "Tool to gain unauthorized access from remote to a system")

What about “Gain access to a remote system by trying logins and passwords”?

> +    (description
> +     "This package provides a tool to gain unauthorized
> +access from remote to a system.  This tool is only for LEGAL purposes!")

How about something like this:

  This package provides a tool to demonstrate how easy it is to gain
  unauthorized access to a system by automatically attempting logins and
  passwords.  It supports a wide range of protocols, including SSH,
  SMTP, and HTTP.

Could you send an updated patch?

Thanks,
Ludo’.
diff mbox series

Patch

From 34a6f226063c49d326966d01e78092a40177a05f Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 24 Feb 2022 19:29:14 +0100
Subject: [PATCH] gnu: Add hydra.

* gnu/packages/password-utils.scm (hydra): New variable.

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index c74ffe5242..cb4c2a3667 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -67,6 +68,7 @@  (define-module (gnu packages password-utils)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aidc)
@@ -103,6 +105,7 @@  (define-module (gnu packages password-utils)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages rdesktop)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages security-token)
@@ -1351,6 +1354,32 @@  (define-public hashcat-utils
 group them into chains.")
     (license license:expat)))
 
+(define-public hydra
+  (package
+    (name "hydra")
+    (version "9.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://salsa.debian.org/pkg-security-team/hydra/-/archive/upstream/"
+                    version "/hydra-upstream-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12m5w2rf2821gl8libbsd7pfz4dqn3g4jxh3mcg4qd2hk1c19qns"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;no test suite
+       #:make-flags (list (string-append "CC="
+                                         ,(cc-for-target)))))
+    (native-inputs (list pkg-config))
+    (inputs (list freerdp gtk+ openssl zlib))
+    (home-page "https://salsa.debian.org/pkg-security-team/hydra")
+    (synopsis "Tool to gain unauthorized access from remote to a system")
+    (description
+     "This package provides a tool to gain unauthorized
+access from remote to a system.  This tool is only for LEGAL purposes!")
+    (license license:agpl3+)))
+
 (define-public bruteforce-luks
   (package
     (name "bruteforce-luks")

base-commit: 437718442ca758a3857702cecfe5c80aa5df272b
-- 
2.38.1