diff mbox series

[bug#35944] gnu: packages: haskell: happy: Disable tests

Message ID 4BD76A21-D533-4B60-9A24-6855225D354E@vllmrt.net
State Accepted
Headers show
Series [bug#35944] gnu: packages: haskell: happy: Disable tests | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Robert Vollmert June 1, 2019, 2:40 p.m. UTC
> On 1. Jun 2019, at 14:56, Robert Vollmert <rob@vllmrt.net> wrote:
>> On 1. Jun 2019, at 14:55, Ludovic Courtès <ludo@gnu.org> wrote:
>> They fail because they run out of memory?
> 
> Indeed, the OOM killer strikes.
> 
>> What would it take to skip just these two tests instead of skipping all
>> the tests?
> 
> I’ll look into it.

Below is a patch that does that. I’m now running into similar issues when
compiling ghc-scientific; should OOM test failures at 2G of memory generally
be considered worth fixing? As an alternative, would it be feasible to
implement a --skip-tests flag for guix build?

From 7b7029d99df7df2ccdbfb4026edd91daa2a5763e Mon Sep 17 00:00:00 2001
From: Robert Vollmert <rob@vllmrt.net>
Date: Tue, 28 May 2019 21:10:24 +0200
Subject: [PATCH] gnu: ghc-happy: Skip memory-hungry tests.

Tests fail reliably for me on a system with 2GB of available RAM, in
`issue93.a.hs` and `issue93.n.hs`.

* gnu/packages/haskell.scm (ghc-happy): Skip test "issue93".
---
 gnu/packages/haskell.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Ludovic Courtès June 1, 2019, 9:30 p.m. UTC | #1
Hi,

Robert Vollmert <rob@vllmrt.net> skribis:

> Below is a patch that does that. I’m now running into similar issues when
> compiling ghc-scientific; should OOM test failures at 2G of memory generally
> be considered worth fixing?

I’d say yes, as long as we’re just talking about a small fraction of the
GHC packages.

> As an alternative, would it be feasible to implement a --skip-tests
> flag for guix build?

That would amount to building a different derivation, so that’s not
really a solution.

> From 7b7029d99df7df2ccdbfb4026edd91daa2a5763e Mon Sep 17 00:00:00 2001
> From: Robert Vollmert <rob@vllmrt.net>
> Date: Tue, 28 May 2019 21:10:24 +0200
> Subject: [PATCH] gnu: ghc-happy: Skip memory-hungry tests.
>
> Tests fail reliably for me on a system with 2GB of available RAM, in
> `issue93.a.hs` and `issue93.n.hs`.
>
> * gnu/packages/haskell.scm (ghc-happy): Skip test "issue93".

I copied the explanation as a comment and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33c9c6484d..be9ab00bfd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1325,6 +1325,14 @@  postfix notation.  For more information on stack based languages, see
         (base32
          "138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-test-issue93
+           (lambda _
+             (substitute* "tests/Makefile"
+               ((" issue93.y ") " "))
+             #t)))))
     (home-page "https://hackage.haskell.org/package/happy")
     (synopsis "Parser generator for Haskell")
     (description "Happy is a parser generator for Haskell.  Given a grammar