[bug#77159,1/7] gnu: girara: Update to 0.4.5.

Message ID 49de5f9484fc7da5a017a8670bcbaf546e2ba28c.1742591224.git.wongandj@icloud.com
State New
Headers
Series Update Zathura and plugins |

Commit Message

Andrew Wong March 21, 2025, 9:11 p.m. UTC
  * gnu/packages/gtk.scm (girara): Update to 0.4.5.
[arguments] <#:phases>: Refactor.
[source]: Switch to url-fetch.

Change-Id: I8e7b512d7f398540855ac00813d71eba59044bb4
---
 gnu/packages/gtk.scm | 55 ++++++++++++++++++--------------------------
 1 file changed, 22 insertions(+), 33 deletions(-)
  

Comments

Liliana Marie Prikler March 22, 2025, 1:31 a.m. UTC | #1
Am Freitag, dem 21.03.2025 um 17:11 -0400 schrieb Andrew Wong:
> * gnu/packages/gtk.scm (girara): Update to 0.4.5.
> [arguments] <#:phases>: Refactor.
> [source]: Switch to url-fetch.
> 
> Change-Id: I8e7b512d7f398540855ac00813d71eba59044bb4
> ---
>  gnu/packages/gtk.scm | 55 ++++++++++++++++++------------------------
> --
>  1 file changed, 22 insertions(+), 33 deletions(-)
> 
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 846103ff9e..ef2ec7ed84 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -2261,45 +2261,34 @@ (define-public perl-pango
>  (define-public girara
>    ;; TODO: Move propagated inputs to inputs after core-updates is
> merged (as
>    ;; of 2024-03)
> +  ;; N: Attempted, doing so causes failure to locate girara-gtk3 in
> packages
> +  ;; that depend on it (as of 2025-03)
>    (package
>      (name "girara")
> -    (version "0.4.3")
> +    (version "0.4.5")
>      (source
>       (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://git.pwmt.org/pwmt/girara")
> -             (commit version)))
> -       (file-name (git-file-name name version))
> +       (method url-fetch)
> +       (uri (string-append
> "https://pwmt.org/projects/girara/download/girara-"
> +                           version ".tar.xz"))
LGTM.
>         (sha256
> -        (base32
> "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
> +        (base32
> "14fspmblgqcc67dsn4lxc45pxbzsky3jnmrna16qb5i7z29pjzvb"))))
>      (arguments
> -     (list
> -      #:phases
> -      #~(modify-phases %standard-phases
> -          (add-before 'check 'start-xserver
> -            ;; Tests require a running X server.
> -            (lambda* (#:key inputs #:allow-other-keys)
> -              (let ((xorg-server (assoc-ref inputs "xorg-server"))
> -                    (display ":1"))
> -                (setenv "DISPLAY" display)
> -
> -                ;; On busy machines, tests may take longer than
> -                ;; the default of four seconds.
> -                (setenv "CK_DEFAULT_TIMEOUT" "20")
> -
> -                ;; Don't fail due to missing '/etc/machine-id'.
> -                (setenv "DBUS_FATAL_WARNINGS" "0")
> -                (zero? (system (string-append xorg-server "/bin/Xvfb
> "
> -                                              display " &")))))))))
> -    (native-inputs
> -     (list pkg-config
> -           check
> -           gettext-minimal
> -           `(,glib "bin")
> -           xorg-server-for-tests))
> -    ;; Listed in 'Requires.private' of 'girara.pc'.
> -    (propagated-inputs (list gtk+ json-glib))
> +     (list #:phases #~(modify-phases %standard-phases
> +                        (add-before 'check 'start-xserver-for-tests
> +                          (lambda* (#:key inputs #:allow-other-keys)
> +                            (setenv "DISPLAY" ":1")
> +                            ;; On busy machines, tests may take
> longer than
> +                            ;; the default of four seconds.
> +                            (setenv "CK_DEFAULT_TIMEOUT" "20")
> +                            ;; Don't fail due to missing
> '/etc/machine-id'.
> +                            (setenv "DBUS_FATAL_WARNINGS" "0")
> +                            ((compose zero? system)
> +                             (string-append (assoc-ref inputs "xorg-
> server")
> +                                            "/bin/Xvfb :1 &")))))))
You don't have to reindent arguments IIUC, and doing so introduces
commit noise.
> +    (native-inputs (list pkg-config gettext-minimal `(,glib "bin") ;
> build
> +                         check xorg-server-for-tests)) ; test
> +    (propagated-inputs (list gtk+ json-glib));See girara.pc
> 'Requires.private'
Same here, you can leave them unchanged.  If you do want to clean them
up, please sort them alphabetically.
>      (build-system meson-build-system)
>      (home-page "https://pwmt.org/projects/girara/")
>      (synopsis "Library for minimalistic gtk+3 user interfaces")

Cheers
  

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 846103ff9e..ef2ec7ed84 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2261,45 +2261,34 @@  (define-public perl-pango
 (define-public girara
   ;; TODO: Move propagated inputs to inputs after core-updates is merged (as
   ;; of 2024-03)
+  ;; N: Attempted, doing so causes failure to locate girara-gtk3 in packages
+  ;; that depend on it (as of 2025-03)
   (package
     (name "girara")
-    (version "0.4.3")
+    (version "0.4.5")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://git.pwmt.org/pwmt/girara")
-             (commit version)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (string-append "https://pwmt.org/projects/girara/download/girara-"
+                           version ".tar.xz"))
        (sha256
-        (base32 "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
+        (base32 "14fspmblgqcc67dsn4lxc45pxbzsky3jnmrna16qb5i7z29pjzvb"))))
     (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-before 'check 'start-xserver
-            ;; Tests require a running X server.
-            (lambda* (#:key inputs #:allow-other-keys)
-              (let ((xorg-server (assoc-ref inputs "xorg-server"))
-                    (display ":1"))
-                (setenv "DISPLAY" display)
-
-                ;; On busy machines, tests may take longer than
-                ;; the default of four seconds.
-                (setenv "CK_DEFAULT_TIMEOUT" "20")
-
-                ;; Don't fail due to missing '/etc/machine-id'.
-                (setenv "DBUS_FATAL_WARNINGS" "0")
-                (zero? (system (string-append xorg-server "/bin/Xvfb "
-                                              display " &")))))))))
-    (native-inputs
-     (list pkg-config
-           check
-           gettext-minimal
-           `(,glib "bin")
-           xorg-server-for-tests))
-    ;; Listed in 'Requires.private' of 'girara.pc'.
-    (propagated-inputs (list gtk+ json-glib))
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'start-xserver-for-tests
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (setenv "DISPLAY" ":1")
+                            ;; On busy machines, tests may take longer than
+                            ;; the default of four seconds.
+                            (setenv "CK_DEFAULT_TIMEOUT" "20")
+                            ;; Don't fail due to missing '/etc/machine-id'.
+                            (setenv "DBUS_FATAL_WARNINGS" "0")
+                            ((compose zero? system)
+                             (string-append (assoc-ref inputs "xorg-server")
+                                            "/bin/Xvfb :1 &")))))))
+    (native-inputs (list pkg-config gettext-minimal `(,glib "bin") ; build
+                         check xorg-server-for-tests)) ; test
+    (propagated-inputs (list gtk+ json-glib));See girara.pc 'Requires.private'
     (build-system meson-build-system)
     (home-page "https://pwmt.org/projects/girara/")
     (synopsis "Library for minimalistic gtk+3 user interfaces")