diff mbox series

[bug#65557] gnu: pencil2d: Fix tests.

Message ID 499c3851ede4c6e239dbd2332006a3e761e29222.1693104877.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65557] gnu: pencil2d: Fix tests. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Aug. 27, 2023, 2:54 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/animation.scm (pencil2d)[arguments]: Use gexps.
Add fix-tests phase.
---
 gnu/packages/animation.scm | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)


base-commit: 28fdf6cc16aee56fdc17a31701b90ace6e512481

Comments

宋文武 Aug. 31, 2023, 10:06 a.m. UTC | #1
Pushed now, closing!
diff mbox series

Patch

diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 9691dd0d80..d6bd3fd03d 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -442,19 +442,24 @@  (define-public pencil2d
     (inputs
      (list qtbase-5 qtxmlpatterns qtmultimedia-5 qtsvg-5))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (invoke "qmake" (string-append "PREFIX=" out)))))
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (plugin-path (getenv "QT_PLUGIN_PATH")))
-               (wrap-program (string-append out "/bin/pencil2d")
-                 `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))
-               #t))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-tests
+            (lambda _
+              ;; Its bundled catch2-2.5.0 fails to build with glibc-2.35.
+              (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
+                         "tests/src/catch.hpp")))
+          (replace 'configure
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (invoke "qmake" (string-append "PREFIX=" out)))))
+          (add-after 'install 'wrap-executable
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out"))
+                    (plugin-path (getenv "QT_PLUGIN_PATH")))
+                (wrap-program (string-append out "/bin/pencil2d")
+                  `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
     (home-page "https://www.pencil2d.org")
     (synopsis "Make 2D hand-drawn animations")
     (description