[bug#77905] gnu: Add highs.

Message ID 49700340b562fc09816dec13bd9028c53e5d05fd.1745000189.git.wz@freeshell.de
State New
Headers
Series [bug#77905] gnu: Add highs. |

Commit Message

Wiktor Żelazny April 18, 2025, 6:17 p.m. UTC
  * gnu/packages/maths.scm (highs): New variable.

Change-Id: Ie842704d4d9c8a4b531ee45aab34a99e59e4b3c4
---
 gnu/packages/maths.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: a4a7ff0319c622cd08aa7461cc88cc6608fe62cb
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4be9e71320..0eee1584c5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -11158,3 +11158,27 @@  (define-public exprtk
 expression parsing and evaluation.")
     (home-page "https://www.partow.net/programming/exprtk/index.html")
     (license license:expat)))
+
+(define-public highs
+  (let ((commit "v1.10.0")
+        (revision "1"))
+    (package
+      (name "highs")
+      (version (git-version "1.10.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ERGO-Code/HiGHS")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "19q99nkk6r6k91gxp8a5rjil1399qyfgfc6jqlg2gd82vpcw8c8b"))))
+      (build-system cmake-build-system)
+      (home-page "https://highs.dev")
+      (synopsis "High performance software for linear optimization")
+      (description
+       "HiGHS provides serial and parallel solvers for large-scale
+sparse linear programming (LP), mixed-integer programming (MIP), and quadratic
+programming (QP) models")
+      (license license:expat))))