diff mbox series

[bug#70924,03/10] gnu: Add python-async-lru.

Message ID 4954ddcec07219ed0110f8fa5f038de716703092.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-async-lru): New variable.

Change-Id: I980f53542ae44c6a2127677171d16b29aa4a3d64
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 901b0b25c5..73b2753dc3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22326,6 +22326,31 @@  (define-public python-kivymd
 Design spec without sacrificing ease of use or application performance.")
     (license license:expat)))
 
+(define-public python-async-lru
+  (package
+    (name "python-async-lru")
+    (version "2.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "async-lru" version))
+       (sha256
+        (base32 "09sn3bc3gc2flijm9k8kn4hmbnlkaddhqahb49izy188yrfrm9dq"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest
+                         python-pytest-asyncio
+                         python-pytest-cov
+                         python-pytest-timeout))
+    (propagated-inputs (list python-typing-extensions))
+    (home-page "https://github.com/aio-libs/async-lru")
+    (synopsis "Simple LRU cache for asyncio")
+    (description
+     "This package is a port of Python's built-in @code{functools.lru_cache}
+function for @code{asyncio}.  To better handle async behaviour, it also
+ensures multiple concurrent calls will only result in 1 call to the wrapped
+function, with all awaits receiving the result of that call when it completes.")
+    (license license:expat)))
+
 (define-public python-asyncinject
   (package
     (name "python-asyncinject")