diff mbox series

[bug#70048] gnu: Add python-contexttimer.

Message ID 495145bd3f5d95dfd2e025496e161a8d5002c1f9.1711621671.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#70048] gnu: Add python-contexttimer. | expand

Commit Message

nafkhamdc March 28, 2024, 10:27 a.m. UTC
* gnu/packages/bioinformatics.scm (python-contexttimer): New variable.

Change-Id: I1ed35f1d0190f0e3a60095c7627b6c17552cb4cc
---
 gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d
prerequisite-patch-id: d26b189d1487d0d6a234a8197c5892f1e179e5f5

Comments

Ricardo Wurmus March 28, 2024, 12:31 p.m. UTC | #1
Thanks for the patch.  I applied it but moved it to python-xyz.scm, as
it is nothing to do with bioinformatics.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d18d5d8611..406506f549 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17575,6 +17575,28 @@  (define-public python-pyfaidx
 fasta subsequences.")
     (license license:bsd-3)))
 
+(define-public python-contexttimer
+  (package
+    (name "python-contexttimer")
+    (version "0.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/brouberol/contexttimer")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00a9h06a1wj66935n863qlk4jpl9gvdvzkkhl8xmgqwdkwv0js54"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-decorator python-unittest2))
+    (native-inputs (list python-mock))
+    (home-page "https://github.com/brouberol/contexttimer")
+    (synopsis "Timer as a context manager")
+    (description
+     "This package offers utilities to measure code block or function execution time.")
+    (license license:gpl3)))
+
 (define-public python-cooler
   (package
     (name "python-cooler")