diff mbox series

[bug#51844] gnu: Add libconfini.

Message ID 494612e14139c78af4ff1df4a6925621ab236825.camel@gmail.com
State Accepted
Headers show
Series [bug#51844] gnu: Add libconfini. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Nov. 14, 2021, 1:48 p.m. UTC
* gnu/packages/cpp.scm (libconfini): New variable.
---
 gnu/packages/cpp.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Mathieu Othacehe Dec. 2, 2021, 2:38 p.m. UTC | #1
> * gnu/packages/cpp.scm (libconfini): New variable.

Pushed with minor edits,

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d7a83ae727..a3061a9601 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1141,6 +1141,36 @@  (define-public pcg-cpp
       (home-page "https://www.pcg-random.org")
       (license (list license:expat license:asl2.0))))) ; dual licensed
 
+(define-public libconfini
+  (package
+    (name "libconfini")
+    (version "1.16.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/madmurphy/libconfini")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01g8ai2z4fwshk06k824j6ib8nfb3cwxs5kqpqjvv4k5ayzm892h"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'bootstrap
+           (lambda _ (invoke "sh" "bootstrap" "--noconfigure"))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (home-page "https://madmurphy.github.io/libconfini")
+    (synopsis "INI file parser")
+    (description "libconfini is an INI file parser library written in C. It
+focuses on standardization and parsing exactness and is at ease with almost
+every type of file containing key/value pairs.")
+    (license license:gpl3+)))
+
 (define-public libcutl
   (package
     (name "libcutl")