diff mbox series

[bug#38911] gnu: Add sushi.

Message ID 491c0b3fba5ad3dc86fa0a2a16a845ad3b74c6ab.camel@disroot.org
State Accepted
Headers show
Series [bug#38911] gnu: Add sushi. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 4, 2020, 1:36 a.m. UTC
Hello Guix!

Please find the attached patch to add sushi.

NOTE: This patch depends on the patch #38909.

Regards,
RG.

Comments

Raghav Gururajan Jan. 14, 2020, 10:22 p.m. UTC | #1
Sushi v2
Ludovic Courtès Jan. 15, 2020, 9:40 p.m. UTC | #2
"Raghav Gururajan" <raghavgururajan@disroot.org> skribis:

> From c988b8eece06357e26adbb748cb55e1c6b640314 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Tue, 14 Jan 2020 17:18:28 -0500
> Subject: [PATCH] gnu: Add sushi.
>
> * gnu/packages/gnome.scm (sushi): New variable.

I tweaked spelling and indentation and committed.

Thanks!

Ludo’.
diff mbox series

Patch

From 090aede2a479bff1cd976875a6e462a7e5f1961c Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 20:28:26 -0500
Subject: [PATCH] gnu: Add sushi.

* gnu/packages/gnome.scm (sushi): New variable.
---
 gnu/packages/gnome.scm | 54 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ac1bea1f45..b665d02f33 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9432,6 +9432,60 @@  and a high score table.")
     (home-page "https://wiki.gnome.org/Apps/Mahjongg")
     (license license:gpl2+)))
 
+(define-public sushi
+  (package
+   (name "sushi")
+   (version "3.32.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "02idvqjk76lii9xyg3b1yz4rw721709bdm5j8ikjym6amcghl0aj"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:glib-or-gtk? #t
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'glib-or-gtk-wrap 'wrap-typelib
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((prog (string-append (assoc-ref outputs "out")
+                                       "/bin/sushi")))
+              ;; put existing typelibs before sushi's deps, so as to correctly
+              ;; infer gdk-pixbuf
+              (wrap-program prog
+                `("GI_TYPELIB_PATH" suffix (,(getenv "GI_TYPELIB_PATH"))))
+              #t))))))
+   (native-inputs
+    `(("glib:bin" ,glib "bin")
+      ("gettext" ,gettext-minimal)
+      ("gobject-introspection" ,gobject-introspection)
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("clutter" ,clutter)
+      ("clutter-gst" ,clutter-gst)
+      ("clutter-gtk" ,clutter-gtk)
+      ("evince" ,evince)
+      ("freetype" ,freetype)
+      ("gdk-pixbuf" ,gdk-pixbuf)
+      ("gjs" ,gjs)
+      ("gst-plugins-base" ,gst-plugins-base)
+      ("gstreamer" ,gstreamer)
+      ("gtksourceview" ,gtksourceview-3)
+      ("harfbuzz" ,harfbuzz)
+      ("libepoxy" ,libepoxy)
+      ("libmusicbrainz" ,libmusicbrainz)
+      ("libxml2" ,libxml2)
+      ("neon" ,neon)
+      ("webkitgtk" ,webkitgtk)))
+   (synopsis "File previewer for GNOME desktop")
+   (description "Sushi is a dbus-activated service that allows
+applications to preview files on GNOME desktop.")
+   (home-page "https://gitlab.gnome.org/GNOME/sushi")
+   (license license:gpl2)))
+
 (define-public gnome-themes-extra
   (package
     (name "gnome-themes-extra")
-- 
2.24.1