diff mbox series

[bug#66525,v2,04/10] gnu: python-dbusmock: Rewrite phases as a gexp.

Message ID 48b4d13af78919c35ae4389fb46fd1c124a7bc30.1697982039.git.ludo@gnu.org
State New
Headers show
Series Remove dependency of polkit, python-dbusmock, etc. on (guix build syscalls) | expand

Commit Message

Ludovic Courtès Oct. 22, 2023, 1:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-dbusmock)[arguments]: Use gexps.
---
 gnu/packages/python-xyz.scm | 62 +++++++++++++++++++------------------
 1 file changed, 32 insertions(+), 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 782d1fae6f..4929c6dcc7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27165,37 +27165,39 @@  (define-public python-dbusmock
          "1nwl0gzzds2g1w1gfxfzlgrkb5hr1rrdyn619ml25c6b1rjyfk3g"))))
     (build-system python-build-system)
     (arguments
-     `(#:modules ((guix build python-build-system)
-                  (guix build utils)
-                  (ice-9 match))
+     (list #:modules `((guix build python-build-system)
+                       (guix build utils)
+                       (ice-9 match))
 
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "tests/test_code.py"
-               (("/bin/bash") (which "bash")))
-             (substitute* "dbusmock/testcase.py"
-               (("'dbus-daemon'")
-                (string-append "'" (assoc-ref inputs "dbus")
-                               "/bin/dbus-daemon'")))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (match (primitive-fork)
-                 (0                     ;child process
-                  (execlp "pytest" "pytest" "-vv"))
-                 (pytest-pid
-                  (let loop ()
-                    ;; Reap child processes; otherwise, python-dbusmock would
-                    ;; waste time polling for the dbus processes it spawns to
-                    ;; be reaped, in vain.
-                    (match (waitpid WAIT_ANY)
-                      ((pid . status)
-                       (if (= pid pytest-pid)
-                           (unless (zero? status)
-                             (error "`pytest' exited with status" status))
-                           (loop)))))))))))))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-paths
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "tests/test_code.py"
+                     (("/bin/bash")
+                      (which "bash")))
+                   (substitute* "dbusmock/testcase.py"
+                     (("'dbus-daemon'")
+                      (string-append "'" (assoc-ref inputs "dbus")
+                                     "/bin/dbus-daemon'")))))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (match (primitive-fork)
+                       (0 ;child process
+                        (execlp "pytest" "pytest" "-vv"))
+                       (pytest-pid
+                        (let loop ()
+                          ;; Reap child processes; otherwise, python-dbusmock
+                          ;; would waste time polling for the dbus processes
+                          ;; it spawns to be reaped, in vain.
+                          (match (waitpid WAIT_ANY)
+                            ((pid . status)
+                             (if (= pid pytest-pid)
+                                 (unless (zero? status)
+                                   (error "`pytest' exited with status"
+                                          status))
+                                 (loop)))))))))))))
     (native-inputs
      (list dbus python-pytest which))
     (inputs