diff mbox series

[bug#64176] gnu: Add nscde

Message ID 48b10d297346a9edcbedf8a34fa489650545db0b.1687200595.git.atai@atai.org
State New
Headers show
Series [bug#64176] gnu: Add nscde | expand

Commit Message

Andy Tai June 19, 2023, 6:50 p.m. UTC
* gnu/packages/fvwm.scm (nscde): New variable
---
 gnu/packages/fvwm.scm | 63 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 62 insertions(+), 1 deletion(-)


base-commit: dc90c0807d0a46cdd4b0a2c2b3f9becca9f97285

Comments

Ludovic Courtès June 25, 2023, 9:37 p.m. UTC | #1
Hi,

Andy Tai <atai@atai.org> skribis:

> * gnu/packages/fvwm.scm (nscde): New variable

Could you address ‘guix lint’ warnings?  (Also visible at
<https://qa.guix.gnu.org/issue/64176>.)

> +    (synopsis "Not so Common Desktop Environment")
> +    (description "Modern and functional CDE desktop based on FVWM.")

Please see
<https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.

Could you send a v2?

Thanks,
Ludo’.
Andy Tai June 25, 2023, 11:46 p.m. UTC | #2
will do

On Sun, Jun 25, 2023 at 2:37 PM Ludovic Courtès <ludo@gnu.org> wrote:

> Hi,
>
> Andy Tai <atai@atai.org> skribis:
>
> > * gnu/packages/fvwm.scm (nscde): New variable
>
> Could you address ‘guix lint’ warnings?  (Also visible at
> <https://qa.guix.gnu.org/issue/64176>.)
>
> > +    (synopsis "Not so Common Desktop Environment")
> > +    (description "Modern and functional CDE desktop based on FVWM.")
>
> Please see
> <https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.
>
> Could you send a v2?
>
> Thanks,
> Ludo’.
>
diff mbox series

Patch

diff --git a/gnu/packages/fvwm.scm b/gnu/packages/fvwm.scm
index 872810c658..6201ed0622 100644
--- a/gnu/packages/fvwm.scm
+++ b/gnu/packages/fvwm.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,17 +21,30 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages fvwm)
-  #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module ((guix licenses) #:select (gpl2+ gpl3))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages compton)
+  #:use-module (gnu packages dunst)
+  #:use-module (gnu packages fonts)
   #:use-module (gnu packages fribidi)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gkrellm)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages shells)
+  #:use-module (gnu packages stalonetray)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))
 
 (define-public fvwm
@@ -81,3 +95,50 @@  (define-public fvwm
 window manager for the X Window system.")
     (home-page "https://www.fvwm.org/")
     (license gpl2+)))
+
+(define-public nscde
+  (package
+    (name "nscde")
+    (version "2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/NsCDE/NsCDE/archive/refs/tags/"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "15xjars33k16w1sn6xlmbdfrn6183ah3yj5p8igqc6whdgqxakzw"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config mksh))
+    (inputs (list gettext-minimal
+                  fvwm
+                  font-dejavu
+                  fribidi
+                  dunst
+                  gkrellm
+                  gtk+
+                  imagemagick
+                  libxpm
+                  libxext
+                  libxft
+                  libxt
+                  rofi
+                  picom
+                  python
+                  python-pyyaml
+                  python-qtpy
+                  stalonetray
+                  xclip
+                  xdpyinfo
+                  xorg-rgb
+                  xprop
+                  xrefresh
+                  xscreensaver
+                  xset
+                  xsettingsd
+                  xterm))
+    (synopsis "Not so Common Desktop Environment")
+    (description "Modern and functional CDE desktop based on FVWM.")
+    (home-page "https://github.com/NsCDE/NsCDE")
+    (license gpl3)))
+