diff mbox series

[bug#40494] new package: fulcrum

Message ID 4863435.31r3eYUQgx@cherry
State Accepted
Headers show
Series [bug#40494] new package: fulcrum | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via April 7, 2020, 7:29 p.m. UTC

Comments

Nicolas Goaziou April 10, 2020, 4:45 p.m. UTC | #1
Hello,

Tom Zander via Guix-patches via <guix-patches@gnu.org> writes:

> From d53bb971f61b81ed0b269d1b4aafe6d328ed591e Mon Sep 17 00:00:00 2001
> From: TomZ <tomz@freedommail.ch>
> Date: Tue, 7 Apr 2020 20:48:45 +0200
> Subject: [PATCH] Add Flowee Fulcrum to the finance file

Thank you!

I added a proper commit message, expounded "SPV" in description, and
pushed as 3e6aa0ce968c79869a7a1dcfcfe682865d16ad45.

Regards,
diff mbox series

Patch

From d53bb971f61b81ed0b269d1b4aafe6d328ed591e Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Tue, 7 Apr 2020 20:48:45 +0200
Subject: [PATCH] Add Flowee Fulcrum to the finance file

---
 gnu/packages/finance.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ea1fcbe9d4..940644582a 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
 ;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1401,6 +1402,45 @@  electronic cash system.  This package provides a command line client and
 a Qt GUI.")
     (license license:expat)))
 
+(define-public fulcrum
+  (package
+    (name "fulcrum")
+    (version "1.0.5b")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v"
+                                 version "/fulcrum-v" version ".tar.gz"))
+             (sha256
+               (base32
+               "1c1hkik8avill8ha33g76rk4b03j5ac8wiml69q4jav7a63ywgfy"))))
+
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+       ;; call qmake instead of configure to create a makefile.
+       (replace 'configure
+         (lambda _
+            (invoke
+               "qmake"
+               (string-append "PREFIX=" %output)
+               "features="))))))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("rocksdb" ,rocksdb)
+       ("zlib" ,zlib)
+       ("python" ,python)))
+    (native-inputs
+     `(("qttools" ,qttools)))
+    (home-page "https://gitlab.com/FloweeTheHub/fulcrum")
+    (synopsis "Fast & nimble SPV Server for Bitcoin Cash")
+    (description
+     "Flowee Fulcrum is a server that is the back-end for SPV wallets,
+it provides the full API for those walets in a fast and small server.
+The full data is stored in a full node, like Flowee the Hub, which
+Fulcrum connects to over RPC.")
+    (license license:gpl3+)))
+
 (define-public beancount
   (package
     (name "beancount")
-- 
2.25.1