diff mbox series

[bug#42627] gnu: awesome: Fix command completion in the prompt and Lua paths

Message ID 484421596182827@mail.yandex.ru
State Accepted
Headers show
Series [bug#42627] gnu: awesome: Fix command completion in the prompt and Lua paths | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Ivan Kozlov July 31, 2020, 8:18 a.m. UTC
* gnu/packages/wm.scm (awesome): Delete useless ‘env’ invocation in lib/awful/completion.lua.  Change the delimiter for LUA_PATH and LUA_CPATH variables.

Comments

Ludovic Courtès Sept. 24, 2020, 3:43 p.m. UTC | #1
Hi,

Ivan Kozlov <kanichos@yandex.ru> skribis:

> * gnu/packages/wm.scm (awesome): Delete useless ‘env’ invocation in lib/awful/completion.lua.  Change the delimiter for LUA_PATH and LUA_CPATH variables.

Applied.

Thanks and sorry for the long delay!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index def8fdccd2..133865771a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -947,6 +947,9 @@  experience.")
        (modify-phases %standard-phases
          (add-before 'configure 'set-paths
            (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "lib/awful/completion.lua"
+               (("/usr/bin/env")
+                ""))
              ;; The build process needs to load Cairo dynamically.
              (let* ((cairo (string-append (assoc-ref inputs "cairo") "/lib"))
                     (lua-version ,(version-major+minor (package-version lua)))
@@ -995,9 +998,9 @@  experience.")
                     (lua-version ,(version-major+minor (package-version lua)))
                     (lua-lgi (assoc-ref inputs "lua-lgi")))
                (wrap-program (string-append awesome "/bin/awesome")
-                 `("LUA_PATH" suffix
+                 `("LUA_PATH" ";" suffix
                    (,(format #f "~a/share/lua/~a/?.lua" lua-lgi lua-version)))
-                 `("LUA_CPATH" suffix
+                 `("LUA_CPATH" ";" suffix
                    (,(format #f "~a/lib/lua/~a/?.so" lua-lgi lua-version)))
                  `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
                  `("LD_LIBRARY_PATH" suffix (,cairo)))