diff mbox series

[bug#63206] gnu: gnushogi: Fix build.

Message ID 483665ed2ac988be7e19c67fe28b9f9e5acf2a9e.1682952374.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#63206] gnu: gnushogi: Fix build. | expand

Commit Message

gemmaro May 1, 2023, 2:47 p.m. UTC
Hello,

This patch fixes GNU Shogi build.

Since the build is now successful, the actual gnushogi executable and
documents are installed in addition to the COPYING file.

Thanks,
gemmaro.

* gnu/packages/games.scm (gnushogi): Set linker flag to build program.
---
 gnu/packages/games.scm | 42 +++++++++++++++++++++++++-----------------
 1 file changed, 25 insertions(+), 17 deletions(-)


base-commit: 0c6a7e1045cbd06336ef3699734a803a2e4038e5

Comments

gemmaro May 3, 2023, 2:46 a.m. UTC | #1
Hello Games and Toys team,

I'm sorry.  I should have added X-Debbugs-Cc to mention, since this
patch is about games.scm.

Regards,
gemmaro.
Liliana Marie Prikler May 4, 2023, 4:28 a.m. UTC | #2
Hi gemmaro,

Am Montag, dem 01.05.2023 um 23:47 +0900 schrieb gemmaro:
> Hello,
> 
> This patch fixes GNU Shogi build.
> 
> Since the build is now successful, the actual gnushogi executable and
> documents are installed in addition to the COPYING file.
> 
> Thanks,
> gemmaro.
When embedding letteresque communications in a commit, these should go
below the --- line before the diffstat, where git will happily ignore
them.

> * gnu/packages/games.scm (gnushogi): Set linker flag to build
> program.
> ---
>  gnu/packages/games.scm | 42 +++++++++++++++++++++++++---------------
> --
>  1 file changed, 25 insertions(+), 17 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 3391c141e42..a36e2fe55bf 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -76,6 +76,7 @@
>  ;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
>  ;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
>  ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
> +;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2012,24 +2013,31 @@ (define-public gnubik
>      (license license:gpl3+)))
>  
>  (define-public gnushogi
> -  (package
> -    (name "gnushogi")
> -    (version "1.4.2")
> -    (source
> -     (origin
> -      (method url-fetch)
> -      (uri (string-append "mirror://gnu/gnushogi/gnushogi-"
> -                          version ".tar.gz"))
> -      (sha256
> -       (base32
> -        "0a9bsl2nbnb138lq0h14jfc5xvz7hpb2bcsj4mjn6g1hcsl4ik0y"))))
> -    (arguments `(#:tests? #f)) ;; No check target.
> -    (build-system gnu-build-system)
> -    (home-page "https://www.gnu.org/software/gnushogi/")
> -    (synopsis "The game of Shogi (Japanese chess)")
> -    (description  "GNU Shogi is a program that plays the game Shogi
> (Japanese
> +  (let ((ver "1.4.2")
> +        (revision "2"))
There is no need to bump the revision, since the source remains
unchanged.  We also prefer not to let-bind the base version.
> +    (package
> +      (name "gnushogi")
> +      (version (string-append ver "-" revision))
> +      (source (origin
> +                (method url-fetch)
> +                (uri (string-append "mirror://gnu/gnushogi/gnushogi-
> " ver
> +                                    ".tar.gz"))
> +                (sha256
> +                 (base32
> +                 
> "0a9bsl2nbnb138lq0h14jfc5xvz7hpb2bcsj4mjn6g1hcsl4ik0y"))))
> +      (arguments
> +       `(#:phases (modify-phases %standard-phases
> +                    (add-before 'configure 'set-linker-flag
> +                      (lambda _
> +                        (setenv "LDFLAGS" "-z muldefs"))))
Since we're using gnu-build-system, can this by chance be achieved via
#:configure-flags or #:make-flags?
> +         #:tests? #f)) ;No check target.
> +      (build-system gnu-build-system)
> +      (home-page "https://www.gnu.org/software/gnushogi/")
> +      (synopsis "The game of Shogi (Japanese chess)")
> +      (description
> +       "GNU Shogi is a program that plays the game Shogi (Japanese
>  Chess).  It is similar to standard chess but this variant is far
> more complicated.")
> -    (license license:gpl3+)))
> +      (license license:gpl3+))))
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3391c141e42..a36e2fe55bf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -76,6 +76,7 @@ 
 ;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
 ;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2012,24 +2013,31 @@  (define-public gnubik
     (license license:gpl3+)))
 
 (define-public gnushogi
-  (package
-    (name "gnushogi")
-    (version "1.4.2")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/gnushogi/gnushogi-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "0a9bsl2nbnb138lq0h14jfc5xvz7hpb2bcsj4mjn6g1hcsl4ik0y"))))
-    (arguments `(#:tests? #f)) ;; No check target.
-    (build-system gnu-build-system)
-    (home-page "https://www.gnu.org/software/gnushogi/")
-    (synopsis "The game of Shogi (Japanese chess)")
-    (description  "GNU Shogi is a program that plays the game Shogi (Japanese
+  (let ((ver "1.4.2")
+        (revision "2"))
+    (package
+      (name "gnushogi")
+      (version (string-append ver "-" revision))
+      (source (origin
+                (method url-fetch)
+                (uri (string-append "mirror://gnu/gnushogi/gnushogi-" ver
+                                    ".tar.gz"))
+                (sha256
+                 (base32
+                  "0a9bsl2nbnb138lq0h14jfc5xvz7hpb2bcsj4mjn6g1hcsl4ik0y"))))
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (add-before 'configure 'set-linker-flag
+                      (lambda _
+                        (setenv "LDFLAGS" "-z muldefs"))))
+         #:tests? #f)) ;No check target.
+      (build-system gnu-build-system)
+      (home-page "https://www.gnu.org/software/gnushogi/")
+      (synopsis "The game of Shogi (Japanese chess)")
+      (description
+       "GNU Shogi is a program that plays the game Shogi (Japanese
 Chess).  It is similar to standard chess but this variant is far more complicated.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public ltris
   (package