[bug#75420,python-team,03/11] gnu: Add python-pytest-codspeed.

Message ID 482b2dbaf82f97ed17b92d66793392900331829b.1736256868.git.arjan@adriaan.se
State New
Headers
Series Fix python-matrix-nio and pantalaimon builds. |

Commit Message

Arjan Adriaanse Jan. 7, 2025, 2:09 p.m. UTC
  * gnu/packages/python-check.scm (python-pytest-codspeed): New variable.

Change-Id: Ib6937eca74d98ce1bdbd9c9053394a537107825b
---
 gnu/packages/python-check.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e8efb96f5f..1e6debc937 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
 ;;; Copyright © 2024 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2025 Arjan Adriaanse <arjan@adriaan.se>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,6 +49,7 @@  (define-module (gnu packages python-check)
   #:use-module (gnu packages django)
   #:use-module (gnu packages docker)
   #:use-module (gnu packages jupyter)
+  #:use-module (gnu packages libffi)
   #:use-module (gnu packages openstack)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python-build)
@@ -188,6 +190,34 @@  (define-public python-pytest-click
 interfaces with pytest.")
     (license license:expat)))
 
+(define-public python-pytest-codspeed
+  (package
+    (name "python-pytest-codspeed")
+    (version "2.2.1")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/CodSpeedHQ/pytest-codspeed")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0phjjg4ncjgq7j8fvchyag92qx4xvxjw33rkb50admipkz38sbzh"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-cffi
+           python-pytest))
+    (native-inputs
+     (list python-hatchling
+           python-filelock
+           python-pytest
+           python-pytest-cov))
+    (home-page "https://codspeed.io")
+    (synopsis "Pytest plugin to create CodSpeed benchmarks")
+    (description "Pytest plugin to create @code{CodSpeed} benchmarks.")
+    (license license:expat)))
+
 (define-public python-pytest-cram
   (package
     (name "python-pytest-cram")