diff mbox series

[bug#69669,gnome-team,1/1] gnu: girara: Update to 0.4.3.

Message ID 47c1519438f47449ee0f44ecbb4f5d8e443d627f.1709969886.git.vivien@planete-kraus.eu
State New
Headers show
Series Update girara to 0.4.3 | expand

Commit Message

Vivien Kraus March 9, 2024, 7:33 a.m. UTC
* gnu/packages/gtk.scm (girara): Update to 0.4.3.
[native-inputs]: Drop labels.
[propagated-inputs]: Add pango and json-glib.
[arguments]: Convert to list of G-Expressions.

Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966
---
 gnu/packages/gtk.scm | 53 +++++++++++++++++++++++---------------------
 1 file changed, 28 insertions(+), 25 deletions(-)

Comments

Liliana Marie Prikler March 9, 2024, 8:24 a.m. UTC | #1
Am Samstag, dem 09.03.2024 um 08:33 +0100 schrieb Vivien Kraus:
> * gnu/packages/gtk.scm (girara): Update to 0.4.3.
> [native-inputs]: Drop labels.
> [propagated-inputs]: Add pango and json-glib.
> [arguments]: Convert to list of G-Expressions.
> 
> Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966
> ---
Since you are already mixing cosmetic and non-cosmetic changes, you can
also sort the fields.  Inputs typically go after arguments.
>  gnu/packages/gtk.scm | 53 +++++++++++++++++++++++-------------------
> --
>  1 file changed, 28 insertions(+), 25 deletions(-)
> 
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index a00ce71b81..0c1b7fb5a0 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -2132,7 +2132,7 @@ (define-public perl-pango
>  (define-public girara
>    (package
>      (name "girara")
> -    (version "0.3.7")
> +    (version "0.4.3")
>      (source
>       (origin
>         (method git-fetch)
> @@ -2141,31 +2141,34 @@ (define-public girara
>               (commit version)))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
> -    (native-inputs `(("pkg-config" ,pkg-config)
> -                     ("check" ,check)
> -                     ("gettext" ,gettext-minimal)
> -                     ("glib:bin" ,glib "bin")
> -                     ("xorg-server" ,xorg-server-for-tests)))
> -    ;; Listed in 'Requires.private' of 'girara.pc'.
> -    (propagated-inputs (list gtk+))
> +        (base32
> "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
> +    (native-inputs
> +     (list pkg-config
> +           check
> +           gettext-minimal
> +           `(,glib "bin")
> +           xorg-server-for-tests))
> +    ;; Listed in 'Requires.private' or 'Requires' of 'girara.pc'.
> +    (propagated-inputs (list gtk+ pango json-glib))
I'd hazard a guess that some of these are already propagated through
gtk+.
>      (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (add-before 'check 'start-xserver
> -                    ;; Tests require a running X server.
> -                    (lambda* (#:key inputs #:allow-other-keys)
> -                      (let ((xorg-server (assoc-ref inputs "xorg-
> server"))
> -                            (display ":1"))
> -                        (setenv "DISPLAY" display)
> -
> -                        ;; On busy machines, tests may take longer
> than
> -                        ;; the default of four seconds.
> -                        (setenv "CK_DEFAULT_TIMEOUT" "20")
> -
> -                        ;; Don't fail due to missing '/etc/machine-
> id'.
> -                        (setenv "DBUS_FATAL_WARNINGS" "0")
> -                        (zero? (system (string-append xorg-server
> "/bin/Xvfb "
> -                                                      display "
> &")))))))))
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-before 'check 'start-xserver
> +            ;; Tests require a running X server.
> +            (lambda* (#:key inputs #:allow-other-keys)
> +              (let ((xorg-server (assoc-ref inputs "xorg-server"))
> +                    (display ":1"))
> +                (setenv "DISPLAY" display)
> +
> +                ;; On busy machines, tests may take longer than
> +                ;; the default of four seconds.
> +                (setenv "CK_DEFAULT_TIMEOUT" "20")
> +
> +                ;; Don't fail due to missing '/etc/machine-id'.
> +                (setenv "DBUS_FATAL_WARNINGS" "0")
> +                (zero? (system (string-append xorg-server "/bin/Xvfb
> "
> +                                              display " &")))))))))
>      (build-system meson-build-system)
>      (home-page "https://pwmt.org/projects/girara/")
>      (synopsis "Library for minimalistic gtk+3 user interfaces")
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a00ce71b81..0c1b7fb5a0 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2132,7 +2132,7 @@  (define-public perl-pango
 (define-public girara
   (package
     (name "girara")
-    (version "0.3.7")
+    (version "0.4.3")
     (source
      (origin
        (method git-fetch)
@@ -2141,31 +2141,34 @@  (define-public girara
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("check" ,check)
-                     ("gettext" ,gettext-minimal)
-                     ("glib:bin" ,glib "bin")
-                     ("xorg-server" ,xorg-server-for-tests)))
-    ;; Listed in 'Requires.private' of 'girara.pc'.
-    (propagated-inputs (list gtk+))
+        (base32 "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
+    (native-inputs
+     (list pkg-config
+           check
+           gettext-minimal
+           `(,glib "bin")
+           xorg-server-for-tests))
+    ;; Listed in 'Requires.private' or 'Requires' of 'girara.pc'.
+    (propagated-inputs (list gtk+ pango json-glib))
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-before 'check 'start-xserver
-                    ;; Tests require a running X server.
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (let ((xorg-server (assoc-ref inputs "xorg-server"))
-                            (display ":1"))
-                        (setenv "DISPLAY" display)
-
-                        ;; On busy machines, tests may take longer than
-                        ;; the default of four seconds.
-                        (setenv "CK_DEFAULT_TIMEOUT" "20")
-
-                        ;; Don't fail due to missing '/etc/machine-id'.
-                        (setenv "DBUS_FATAL_WARNINGS" "0")
-                        (zero? (system (string-append xorg-server "/bin/Xvfb "
-                                                      display " &")))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'start-xserver
+            ;; Tests require a running X server.
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((xorg-server (assoc-ref inputs "xorg-server"))
+                    (display ":1"))
+                (setenv "DISPLAY" display)
+
+                ;; On busy machines, tests may take longer than
+                ;; the default of four seconds.
+                (setenv "CK_DEFAULT_TIMEOUT" "20")
+
+                ;; Don't fail due to missing '/etc/machine-id'.
+                (setenv "DBUS_FATAL_WARNINGS" "0")
+                (zero? (system (string-append xorg-server "/bin/Xvfb "
+                                              display " &")))))))))
     (build-system meson-build-system)
     (home-page "https://pwmt.org/projects/girara/")
     (synopsis "Library for minimalistic gtk+3 user interfaces")