diff mbox series

[bug#72810,3/4] gnu: Add go-github-com-libp2p-go-yamux-v4.

Message ID 47b11f65fcc7a7b008f0f76fc0de38d34bcb674d.1724620806.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add four libp2p libraries. | expand

Commit Message

Artyom V. Poptsov Aug. 25, 2024, 9:23 p.m. UTC
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-yamux-v4): New
variable.

Change-Id: I2c0303c8253bbadde69aee0f15a83fe504fd7b12
---
 gnu/packages/golang-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 28d5b89040..288d81b7dd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2324,6 +2324,34 @@  (define-public go-github-com-libp2p-go-reuseport
 operating systems.")
     (license license:isc)))
 
+(define-public go-github-com-libp2p-go-yamux-v4
+  (package
+    (name "go-github-com-libp2p-go-yamux-v4")
+    (version "4.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libp2p/go-yamux")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13px8fcjjp02cricabbf3x410jkr8sb6r369nqq1zrgr7v90s22j"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/libp2p/go-yamux/v4"))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-libp2p-go-buffer-pool))
+    (home-page "https://github.com/libp2p/go-yamux")
+    (synopsis "Reuse TCP/UDP ports in Golang")
+    (description
+     "Yamux (Yet another Multiplexer) is a multiplexing library for Golang.  It
+relies on an underlying connection to provide reliability and ordering, such as TCP
+or Unix domain sockets, and provides stream-oriented multiplexing.  It is inspired by
+SPDY but is not interoperable with it.")
+    (license (list license:mpl2.0 license:bsd-3))))
+
 (define-public go-github-com-makeworld-the-better-one-go-gemini
   (package
     (name "go-github-com-makeworld-the-better-one-go-gemini")