diff mbox series

[bug#63038,5/5] gnu: mod-wsgi: Build with httpd/pinned.

Message ID 47933c66001b7bb37e6ef63e39d2f317ef18c11c.1682269908.git.leo@famulari.name
State New
Headers show
Series [bug#63038,1/5] gnu: httpd: Update to 2.4.57 [security fixes]. | expand

Commit Message

Leo Famulari April 23, 2023, 5:11 p.m. UTC
* gnu/packages/web.scm (mod-wsgi)[inputs]: Replace httpd with ...
[native-inputs]: ... httpd/pinned.
[arguments]: Forbid keeping a reference to httpd/pinned.
---
 gnu/packages/web.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c8a1d0123e..07b567e0d1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -335,14 +335,16 @@  (define-public mod-wsgi
                 "1savh6h3qds20mwn1nqasmqzcp57pdhfc9v4b4k78d6q28y0r17s"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                 ; TODO: can't figure out if there are tests
+     `(#:disallowed-references (,httpd/pinned)
+       #:tests? #f                 ; TODO: can't figure out if there are tests
        #:make-flags (list
                      (string-append "DESTDIR="
                                     (assoc-ref %outputs "out"))
                      "LIBEXECDIR=/modules")))
+    (native-inputs
+     `(("httpd" ,httpd/pinned)))
     (inputs
-     `(("httpd" ,httpd)
-       ("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)))
     (synopsis "Apache HTTPD module for Python WSGI applications")
     (description
      "The mod_wsgi module for the Apache HTTPD Server adds support for running