[bug#77902,science-team,2/2] gnu: igraph: Update to 0.10.15.

Message ID 4765db19bd76943e2303a04eae2f77f2a43b445b.1744988258.git.code@greghogan.com
State New
Headers
Series Update SuiteSparse. |

Commit Message

Greg Hogan April 18, 2025, 3:14 p.m. UTC
  * gnu/packages/graph.scm (igraph): Update to 0.10.15.
[source]: Remove patches.
[inputs]: Replace suitesparse-cxsparse with suitesparse.
* gnu/packages/patches/igraph-fix-varargs-integer-size.patch: Delete.
* gnu/local.mk (dist_patch_DATA): Update accordingly.

Change-Id: Iffbfdc83b347f9abf82891f5b97954903d3df3dd
---
 gnu/local.mk                                  |  1 -
 gnu/packages/graph.scm                        |  7 ++--
 .../igraph-fix-varargs-integer-size.patch     | 39 -------------------
 3 files changed, 3 insertions(+), 44 deletions(-)
 delete mode 100644 gnu/packages/patches/igraph-fix-varargs-integer-size.patch
  

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 62cfe230bb..2828d8913f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1610,7 +1610,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/id3lib-CVE-2007-4460.patch			\
   %D%/packages/patches/id3lib-UTF16-writing-bug.patch			\
   %D%/packages/patches/idris-test-ffi008.patch			\
-  %D%/packages/patches/igraph-fix-varargs-integer-size.patch	\
   %D%/packages/patches/ilmbase-fix-tests.patch			\
   %D%/packages/patches/indent-CVE-2024-0911.patch	\
   %D%/packages/patches/inferno-fix-crash.patch		\
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 467a7f661b..af4943c281 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -106,7 +106,7 @@  (define-public plfit
 (define-public igraph
   (package
     (name "igraph")
-    (version "0.10.7")
+    (version "0.10.15")
     (source
      (origin
        (method git-fetch)
@@ -114,7 +114,6 @@  (define-public igraph
              (url "https://github.com/igraph/igraph")
              (commit version)))
        (file-name (git-file-name name version))
-       (patches (search-patches "igraph-fix-varargs-integer-size.patch"))
        (modules '((guix build utils)
                   (ice-9 ftw)
                   (srfi srfi-26)))
@@ -136,7 +135,7 @@  (define-public igraph
                      (("add_sub.*vendor.*") ""))))
        (sha256
         (base32
-         "025f9c2jsawniqkig4l5z3v9aw3ipazmnlsf80b653mns5bvj1yn"))))
+         "0z9jqvl65j4z6brrjlfyykba2bs10az6dx6m8g41snlfnx21a82d"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -201,7 +200,7 @@  (define-public igraph
            ;lapack
            openblas
            plfit
-           suitesparse-cxsparse))
+           suitesparse))
     ;; libxml2 is in the 'Requires.private' of igraph.pc.
     (propagated-inputs (list libxml2))
     (home-page "https://igraph.org")
diff --git a/gnu/packages/patches/igraph-fix-varargs-integer-size.patch b/gnu/packages/patches/igraph-fix-varargs-integer-size.patch
deleted file mode 100644
index 2d7ffd7e68..0000000000
--- a/gnu/packages/patches/igraph-fix-varargs-integer-size.patch
+++ /dev/null
@@ -1,39 +0,0 @@ 
-If the size of int is different from IGRAPH_INTEGER_SIZE, the integer size
-passed to these vararg arguments is different from the assumed one,
-leading to undefined behavior.
-Submitted upstream: https://github.com/igraph/igraph/pull/2423
-
-
-diff -ur a/examples/simple/igraph_union.c b/examples/simple/igraph_union.c
---- a/examples/simple/igraph_union.c
-+++ b/examples/simple/igraph_union.c
-@@ -103,7 +103,7 @@
-     igraph_vector_ptr_init(&glist, 10);
-     for (i = 0; i < igraph_vector_ptr_size(&glist); i++) {
-         VECTOR(glist)[i] = calloc(1, sizeof(igraph_t));
--        igraph_vector_int_init_int_end(&v, -1, i, i + 1, 1, 0, -1);
-+        igraph_vector_int_init_int_end(&v, -1, (int) i, (int) i + 1, 1, 0, -1);
-         igraph_create(VECTOR(glist)[i], &v, 0, IGRAPH_DIRECTED);
-         igraph_vector_int_destroy(&v);
-     }
-@@ -123,7 +123,7 @@
-     igraph_vector_ptr_init(&glist, 10);
-     for (i = 0; i < igraph_vector_ptr_size(&glist); i++) {
-         VECTOR(glist)[i] = calloc(1, sizeof(igraph_t));
--        igraph_vector_int_init_int_end(&v, -1, i, i + 1, 1, 0, -1);
-+        igraph_vector_int_init_int_end(&v, -1, (int) i, (int) i + 1, 1, 0, -1);
-         igraph_create(VECTOR(glist)[i], &v, 0, IGRAPH_UNDIRECTED);
-         igraph_vector_int_destroy(&v);
-     }
-diff -ur a/src/core/matrix.pmt b/src/core/matrix.pmt
---- a/src/core/matrix.pmt
-+++ b/src/core/matrix.pmt
-@@ -1863,7 +1863,7 @@
- #ifdef FPRINTFUNC_ALIGNED
-             FPRINTFUNC_ALIGNED(file, VECTOR(column_width)[j], MATRIX(*m, i, j));
- #else
--            fprintf(file, format, VECTOR(column_width)[j], MATRIX(*m, i, j));
-+            fprintf(file, format, (int) VECTOR(column_width)[j], MATRIX(*m, i, j));
- #endif
-         }
-         fprintf(file, "\n");