diff mbox series

[bug#61678,2/2] gnu: Add smlsharp.

Message ID 475d6cad530869442d8a7372a3d29ddf2cc38eb1.1676987498.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: Add smlsharp. | expand

Commit Message

gemmaro Feb. 21, 2023, 2:33 p.m. UTC
* gnu/packages/sml.scm (smlsharp): New variable.
---
 gnu/packages/sml.scm | 48 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sml.scm b/gnu/packages/sml.scm
index 368abf6cfa..5509667e03 100644
--- a/gnu/packages/sml.scm
+++ b/gnu/packages/sml.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,9 +22,13 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages sml)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages lesstif)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages parallel)
   #:use-module (gnu packages xorg)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
@@ -340,3 +345,46 @@  (define-public smlnj
     (license (license:fsf-free
                "https://www.smlnj.org/license.html"
                "https://www.gnu.org/licenses/license-list#StandardMLofNJ"))))
+
+(define-public smlsharp
+  (package
+    (name "smlsharp")
+    (version "4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/smlsharp/smlsharp/releases/download/v"
+                    version "/smlsharp-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1nv567na798qysyw7bc8aaz0v51f239z0s3w37nzqz4z6qgzni0b"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-build? #t
+       #:parallel-tests? #t
+       #:test-target "test"
+       #:phases (modify-phases %standard-phases
+                  ;; NOTE: Needed for running SML# executables
+                  (add-after 'install 'wrap-programs
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out"))
+                            (libs (map (lambda (name)
+                                         (string-append (assoc-ref inputs name)
+                                                        "/lib"))
+                                       '("gmp" "massivethreads" "glibc"))))
+                        (with-directory-excursion (string-append out "/bin")
+                          (for-each (lambda (file)
+                                      (wrap-program (basename file)
+                                                    `("LIBRARY_PATH" prefix
+                                                      ,libs)) #t)
+                                    (find-files ".")))))))))
+    (inputs (list llvm-11 gmp massivethreads glibc bash-minimal))
+    (home-page "https://smlsharp.github.io/en/")
+    (synopsis
+     "Open source functional programming language compatible with with Standard ML")
+    (description
+     "SML# is an open source functional programming language and have been developed
+by the SML# Delelopment Team.  While maintaining compatibility with Standard ML, it
+provides practically important features such as interoperability with C and
+databases.")
+    (license license:expat)))