diff mbox series

[bug#66821,v2,1/3] gnu: Add pantheon-stylesheet.

Message ID 46fbc22afa0f777079a30f9de6fe987154bea952.1704808651.git.altadil@protonmail.com
State New
Headers show
Series [bug#66821,v2,1/3] gnu: Add pantheon-stylesheet. | expand

Commit Message

altadil Jan. 9, 2024, 1:59 p.m. UTC
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.

Change-Id: I5673a540bd44f6ad59b3aa32affbcb4fc0e19035
---
This is a new version of the patch series, to use the newly released
version of pantheon-stylesheet.
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux.
 gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 8920cf302c5a2fd457a2629afe24cf4768f1fed7
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..161c49e5aa 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@  (define-public pantheon-calculator
 desktop.")
     (license license:gpl3)))
 
+(define-public pantheon-stylesheet
+  (package
+    (name "pantheon-stylesheet")
+    (version "7.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/elementary/stylesheet")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zl3s3995q5qg8cqqlkf8a1va72ghj15b3z4g7n7xppq046mxfia"))))
+    (build-system meson-build-system)
+    (native-inputs (list gettext-minimal)) ;for msgfmt
+    (inputs (list sassc))
+    (synopsis "GTK stylesheet for the Pantheon desktop")
+    (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+    (home-page "https://elementary.io/open-source")
+    (license license:gpl3+)))
+
 (define-public pantheon-terminal
   (package
     (name "pantheon-terminal")