diff mbox series

[bug#40174] gnu: zrythm: update to 0.8.156.

Message ID 46c1ec993845f3742e5997469123d60bd7656d4f.camel@zrythm.org
State Accepted
Headers show
Series [bug#40174] gnu: zrythm: update to 0.8.156. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 8:01 p.m. UTC
Hi,

This patch updates Zrythm to 0.8.156. 

I also added support for SDL2 (alternative audio backend to JACK) and
RtMidi (alternative MIDI backend to JACK) so Zrythm can be used without
JACK. SDL2 and RtMidi use ALSA and ALSA sequencer respectively, which
unlike JACK require no extra configuration to use them.

Thanks,
Alex

Comments

Mathieu Othacehe March 23, 2020, 8:05 p.m. UTC | #1
Hello Alexandros,

Could you separate the update part from the rest and propose two
different patches?

Thanks,

Mathieu
diff mbox series

Patch

From ebbdffedd65f5d2d10f4ca2e6dc7d029eb00ca31 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:56:43 +0000
Subject: [PATCH] gnu: zrythm: update to 0.8.156.

* gnu/packages/music.scm (zrythm): Update to 0.8.156.
---
 gnu/packages/music.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 468be9937f..05f5ef5697 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5161,7 +5161,7 @@  and as an LV2 plugin.")
 (define-public zrythm
   (package
     (name "zrythm")
-    (version "0.7.573")
+    (version "0.8.156")
     (source
       (origin
         (method url-fetch)
@@ -5169,13 +5169,14 @@  and as an LV2 plugin.")
                             version ".tar.xz"))
         (sha256
           (base32
-            "075gq478xbzz5ql4fsrgfzhgxi7z26k6034lhlkmm0klfcb8j9mg"))))
+            "0m6052msvgrvs6zy3xiz0vjkf9mbq7w4dhikfmdwqry6c86gkd23"))))
    (build-system meson-build-system)
    (arguments
     `(#:glib-or-gtk? #t
       #:configure-flags
       `("-Denable_tests=true" "-Dmanpage=true"
-        "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+        "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true"
+        "-Denable_rtmidi=true" "-Denable_sdl=true")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-xdg-open
@@ -5194,18 +5195,19 @@  and as an LV2 plugin.")
       ("gettext" ,gettext-minimal)
       ("glibc" ,glibc)
       ("gtk+" ,gtk+)
+      ("libaudec" ,libaudec)
       ("libcyaml" ,libcyaml)
       ("libsamplerate" ,libsamplerate)
       ("libsndfile" ,libsndfile)
       ("libyaml" ,libyaml)
       ("lilv" ,lilv)
-      ("xdg-utils" ,xdg-utils)
-      ("rubberband" ,rubberband)))
+      ("rubberband" ,rubberband)
+      ("rtmidi" ,rtmidi)
+      ("sdl2" ,sdl2)
+      ("xdg-utils" ,xdg-utils)))
    (native-inputs
      `(("pkg-config" ,pkg-config)
        ("help2man" ,help2man)
-       ("libaudec" ,libaudec)
-       ("lv2" ,lv2)
        ("glib" ,glib "bin"))) ;for 'glib-compile-resources'
    (synopsis "Digital audio workstation focusing on usability")
    (description "Zrythm is a digital audio workstation designed to be
-- 
2.25.1