[bug#77710] gnu: Add cadaver.

Message ID 4685ccedfac83946d228e5453ebb97d4672f189b.1744298250.git.dk@junkeria.club
State New
Headers
Series [bug#77710] gnu: Add cadaver. |

Commit Message

Junker April 10, 2025, 3:20 p.m. UTC
  * gnu/packages/dav.scm (cadaver): New variable.
* gnu/packages/dav.scm: add (guix licenses) prefix.

Change-Id: Iffe515ea157714497630b287356bbfa0c3ba4b9a
---
 gnu/packages/dav.scm | 40 ++++++++++++++++++++++++++++++++++++----
 1 file changed, 36 insertions(+), 4 deletions(-)


base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
  

Comments

Noé Lopez April 10, 2025, 8:17 p.m. UTC | #1
Hi Junker,

Thanks for the patch, it looks pretty good.

It think it would be better to split the (guix license) prefix change
into a different commit.

Could you send a new version in two patches?

Have a nice day,
Noé
  

Patch

diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 546118055f..49c2b027cd 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2022, 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,15 +24,17 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages dav)
+  #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system pyproject)
   #:use-module (guix download)
   #:use-module (guix gexp)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (gnu packages)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
@@ -40,8 +43,37 @@  (define-module (gnu packages dav)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages time)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages xml))
 
+(define-public cadaver
+  (package
+    (name "cadaver")
+    (version "0.26")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://notroj.github.io/cadaver/cadaver-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "0mbv6mkdhxqhdq5kgn821if10h184m1xlpqq0vpxj19mvwyf8dlj"))))
+    (build-system gnu-build-system)
+    (inputs (list neon
+                  openssl
+                  libxml2))
+    (native-inputs (list pkg-config))
+    (arguments '(#:configure-flags (list "--with-ssl=openssl")
+                 #:tests? #f)) ; no check target
+    (home-page "https://notroj.github.io/cadaver/")
+    (synopsis "Command-line WebDAV client")
+    (description
+     "Cadaver is a command-line client for WebDAV server operations.  It
+supports a variety of WebDAV features and provides an interactive
+command-line environment with support for file manipulation on remote WebDAV
+servers.")
+    (license license:gpl2+)))
+
 (define-public radicale
   (package
     (name "radicale")
@@ -79,7 +111,7 @@  (define-public radicale
 Instead, it supports the CalDAV and CardDAV implementations of popular
 clients.")
     (home-page "https://radicale.org/")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public xandikos
   (package
@@ -117,7 +149,7 @@  (define-public xandikos
 @item Automatically keep history and back up
 @item Works with all tested CalDAV and CardDAV clients
 @end itemize")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public vdirsyncer
   (package
@@ -169,4 +201,4 @@  (define-public vdirsyncer
 local data can then be accessed via a variety of programs, none of which
 have to know or worry about syncing to a server.")
     (home-page "https://github.com/pimutils/vdirsyncer")
-    (license bsd-3)))
+    (license license:bsd-3)))