[bug#77590,v4,5/5] gnu: satdump: Fix RUNPATH for a plugin.
Commit Message
* gnu/packages/radio.scm (satdump)[arguments]: Add 'fix-runpath phase.
---
gnu/packages/radio.scm | 17 ++++++++++++++++-
1 file changed, 16 insertions(+), 1 deletion(-)
@@ -3245,7 +3245,22 @@ (define-public satdump
volk
(list zstd "lib")))
(arguments
- (list #:tests? #f)) ; No test suite
+ (list
+ #:tests? #f ; No test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; The RUNPATH of this shared library is missing the
+ ;; .../lib/satdump/plugins directory, which fails the
+ ;; 'validate-runpath' phase.
+ (add-after 'unpack 'fix-runpath
+ (lambda _
+ (substitute* "plugins/official_products_support/CMakeLists.txt"
+ (("add_library\\(official_products_loader_support.*" orig)
+ (string-append
+ orig "\n" "set_target_properties("
+ "official_products_loader_support"
+ " PROPERTIES INSTALL_RPATH \""
+ #$output "/lib:" #$output "/lib/satdump/plugins\")\n"))))))))
(home-page "https://www.satdump.org/")
(synopsis "Satellite data processing software")
(description "SatDump is a generic satellite data processing software.