A few description mistakenly use @{foo} instead of @code{foo} which
results in broken formatting in guix search.
* gnu/packages/bioinformatics.scm (umi-tools),
* gnu/packages/cran.scm (r-ggside),
* gnu/packages/crates-apple.scm: (rust-commoncrypto-0.2),
* gnu/packages/crates-io.scm: (rust-ndarray-rand-0.15),
* gnu/packages/emacs-xyz.scm (emacs-load-relative, emacs-el-x)
(emacs-helm-org-ql, emacs-consult-lsp),
* gnu/packages/golang-xyz.scm (go-github-com-songmu-gitconfig),
* gnu/packages/haskell-xyz.scm (ghc-text-short, ghc-validation),
* gnu/packages/image.scm (imgp),
* gnu/packages/perl-check.scm (perl-test-file-contents),
* gnu/packages/perl-web.scm (perl-uri-db),
* gnu/packages/perl.scm (perl-clipboard, perl-module-refresh),
* gnu/packages/python-xyz.scm (python-ddlparse, python-black-macchiato)
(python-pysendfile),
* gnu/packages/qt.scm (qt5compat),
* gnu/packages/ruby.scm (ruby-ruby-engine, ruby-httpclient),
* gnu/packages/sagemath.scm (python-memory-allocator),
* gnu/packages/spreadsheet.scm (sc-im),
* gnu/packages/time.scm (python-pendulum):
[description]: Fix malformed macros.
Change-Id: I3ed755a54aecf40bf0c5c982f9e70b7cd3689de7
---
gnu/packages/bioinformatics.scm | 2 +-
gnu/packages/cran.scm | 2 +-
gnu/packages/crates-apple.scm | 2 +-
gnu/packages/crates-io.scm | 2 +-
gnu/packages/emacs-xyz.scm | 8 ++++----
gnu/packages/golang-xyz.scm | 2 +-
gnu/packages/haskell-xyz.scm | 4 ++--
gnu/packages/image.scm | 2 +-
gnu/packages/perl-check.scm | 2 +-
gnu/packages/perl-web.scm | 2 +-
gnu/packages/perl.scm | 4 ++--
gnu/packages/python-xyz.scm | 6 +++---
gnu/packages/qt.scm | 2 +-
gnu/packages/ruby.scm | 4 ++--
gnu/packages/sagemath.scm | 2 +-
gnu/packages/spreadsheet.scm | 2 +-
gnu/packages/time.scm | 2 +-
17 files changed, 25 insertions(+), 25 deletions(-)
base-commit: 364694773ef1c61d4c9ec73e24f73642786486ca
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: b6d30068ce4971d4d8e67517229916df4e76c529
prerequisite-patch-id: c99e71b3eaa726b8ecf2d9b782d5a6a51476e702
prerequisite-patch-id: 08fa3e98a432063db118aa1502c6bd0166415bdd
prerequisite-patch-id: 95bb686bc7dc0961b89a2900a368f270de065d94
prerequisite-patch-id: f56033bf148a2fdfb5d9321315bdff877ebdb7ba
prerequisite-patch-id: 6d43f84387c6ec611389d6f16c1809cc28a29365
prerequisite-patch-id: 73fabf1570be45886923df86ca4c66e4330c3752
prerequisite-patch-id: 2ed8951b99f17bac7694d7e2c3ed0440e650b0c1
prerequisite-patch-id: 09df1d4083ee7abc4f2f346f8576be31db4d193d
prerequisite-patch-id: c506c35f577adaeac5fc9f96517c92b1ea2e1135
prerequisite-patch-id: bc918233a0b494eeddb04159bbb8545a731e6e71
prerequisite-patch-id: 2bcaa77f2fb80dc68568b4a9f134006786a12dd2
prerequisite-patch-id: dd019f8e252158eea8fe59f118f0f03742ac4f93
prerequisite-patch-id: bace844ae66e50873074acf659ea8fc33796ac73
@@ -21691,7 +21691,7 @@ (define-public umi-tools
genetic sequences. There are six tools: the @code{extract} and
@code{whitelist} commands are used to prepare a fastq containing UMIs @code{+/-}
cell barcodes for alignment. The remaining commands, @code{group},
-@code{dedup}, and @{count}/@code{count_tab}, are used to identify PCR
+@code{dedup}, and @code{count}/@code{count_tab}, are used to identify PCR
duplicates using the UMIs and perform different levels of analysis depending
on the needs of the user.")
(license license:expat)))
@@ -8173,7 +8173,7 @@ (define-public r-ggside
(synopsis "Side grammar graphics that extends @code{ggplot2}")
(description
"The grammar of graphics as shown in @code{ggplot2} has provided an
-expressive API for users to build plots. This package @{ggside} extends
+expressive API for users to build plots. This package @code{ggside} extends
@code{ggplot2} by allowing users to add graphical information about one of the
main panel's axis using a familiar @code{ggplot2} style API with tidy data.
This package is particularly useful for visualizing metadata on a discrete
@@ -389,7 +389,7 @@ (define-public rust-commoncrypto-0.2
("rust-commoncrypto-sys" ,rust-commoncrypto-sys-0.2))))
(home-page "https://github.com/malept/rust-commoncrypto")
(synopsis "Idiomatic Rust wrappers for Mac OS X's CommonCrypto library")
- (description "The @{commoncrypto} library provides Rust FFI bindings and
+ (description "The @code{commoncrypto} library provides Rust FFI bindings and
idiomatic wrappers for Mac OS X's CommonCrypto library.")
(license license:expat)))
@@ -45108,7 +45108,7 @@ (define-public rust-ndarray-rand-0.15
(synopsis "Constructors for randomized arrays")
(description
"This package provides constructors for randomized arrays. It provides
-@{rand} integration for @{ndarray}.")
+@code{rand} integration for @code{ndarray}.")
(license (list license:expat license:asl2.0))))
(define-public rust-ndk-0.9
@@ -14658,7 +14658,7 @@ (define-public emacs-load-relative
(description
"Provides functions which facilitate writing multi-file Emacs packages
and running from the source tree without having to \"install\" code or fiddle
-with @{load-path}.
+with @code{load-path}.
The main function, @code{load-relative}, loads an Emacs Lisp file relative to
another (presumably currently running) Emacs Lisp file.")
@@ -16736,7 +16736,7 @@ (define-public emacs-el-x
#t)))))
(home-page "https://github.com/sigma/el-x")
(synopsis "Emacs Lisp extensions")
- (description "command@{emacs-el-x} defines the @code{dflet} macro to
+ (description "@command{emacs-el-x} defines the @code{dflet} macro to
provide the historic behavior of @code{flet}, as well as
@code{declare-function} stub for older Emacs.")
(license license:gpl2+)))
@@ -26577,7 +26577,7 @@ (define-public emacs-helm-org-ql
emacs-s))
(synopsis "Helm commands for @code{emacs-org-ql}")
(description "This package provides @code{emacs-helm} commands for
-@{emacs-org-ql}, a Lispy query language for Org files, allowing for actions to
+@code{emacs-org-ql}, a Lispy query language for Org files, allowing for actions to
be performed based on search criteria.")))
(define-public emacs-bing-dict
@@ -43064,7 +43064,7 @@ (define-public emacs-consult-lsp
(synopsis "LSP mode and Consult helping each other")
(description
"@code{emacs-consult-lsp} provides helpers for interactively selecting LSP
-workspace diagnostics, symbols, and file symbols from @{emacs-lsp-mode}
+workspace diagnostics, symbols, and file symbols from @code{emacs-lsp-mode}
by leveraging @code{emacs-consult} APIs.")
(license license:expat)))
@@ -13857,7 +13857,7 @@ (define-public go-github-com-songmu-gitconfig
(home-page "https://github.com/songmu/gitconfig")
(synopsis "Go library to get configuration values from gitconfig")
(description
- "@{gitconfig} is a package to get configuration values from gitconfig.")
+ "@code{gitconfig} is a package to get configuration values from gitconfig.")
(license license:expat)))
(define-public go-github-com-soniakeys-quant
@@ -8549,7 +8549,7 @@ (define-public ghc-text-short
The main difference between @code{Text} and @code{ShortText} is that
@code{ShortText} uses UTF-8 instead of UTF-16 internally and also doesn't
support zero-copy slicing (thereby saving 2 words). Consequently, the memory
-footprint of a (boxed) @{ShortText} value is 4 words (2 words when unboxed)
+footprint of a (boxed) @code{ShortText} value is 4 words (2 words when unboxed)
plus the length of the UTF-8 encoded payload.")
(license license:bsd-3)))
@@ -13891,7 +13891,7 @@ (define-public ghc-validation
The @code{Validation} data type is isomorphic to @code{Either}, but has an
instance of @code{Applicative} that accumulates on the error side. That is to
say, if two (or more) errors are encountered, they are appended using a
-@{Semigroup} operation.
+@code{Semigroup} operation.
As a consequence of this @code{Applicative} instance, there is no
corresponding @code{Bind} or @code{Monad} instance. @code{Validation} is an
@@ -1825,7 +1825,7 @@ (define-public imgp
while saving significantly on storage.
This package may optionally be built with @code{python-pillow-simd} in place
-of @{python-pillow} for SIMD parallelism.")
+of @code{python-pillow} for SIMD parallelism.")
(license license:gpl3+)))
(define-public pngsuite
@@ -662,7 +662,7 @@ (define-public perl-test-file-contents
(home-page "https://metacpan.org/release/Test-File-Contents")
(synopsis "Test routines for examining the contents of files")
(description
- "@{Test::File::Contents} provides functions for testing the contents of
+ "@code{Test::File::Contents} provides functions for testing the contents of
files.")
(license perl-license)))
@@ -84,7 +84,7 @@ (define-public perl-uri-db
(home-page "https://metacpan.org/release/URI-db")
(synopsis "Handle database URIs")
(description
- "This module defines a format for database URIs, and provides a @{URI}
+ "This module defines a format for database URIs, and provides a @code{URI}
class to handle these.")
(license license:perl-license)))
@@ -2010,7 +2010,7 @@ (define-public perl-clipboard
(propagated-inputs (list perl-cgi perl-uri))
(home-page "https://metacpan.org/release/Clipboard")
(synopsis "Copy and paste with any OS")
- (description "@{Clipboard} provides functionality to copy and
+ (description "@code{Clipboard} provides functionality to copy and
paste with any OS.")
(license license:perl-license)))
@@ -13588,7 +13588,7 @@ (define-public perl-module-refresh
(native-inputs (list perl-path-class perl-module-install))
(home-page "https://metacpan.org/release/Module-Refresh")
(synopsis "Refresh %INC files when updated on disk")
- (description "@{Module::Refresh} provides ways to refresh %INC files
+ (description "@code{Module::Refresh} provides ways to refresh %INC files
when updated on disk.")
(license license:perl-license)))
@@ -6917,7 +6917,7 @@ (define-public python-ddlparse
(propagated-inputs (list python-pyparsing))
(home-page "https://github.com/shinichi-takii/ddlparse")
(synopsis "Parses and converts DDL to BigQuery JSON schema")
- (description "This package provides @{ddlparse}, a Python library to parse
+ (description "This package provides @code{ddlparse}, a Python library to parse
and convert DDL to BigQuery JSON schema.")
(license license:bsd-3)))
@@ -9581,7 +9581,7 @@ (define-public python-black-macchiato
(home-page "https://github.com/wbolster/black-macchiato")
(synopsis "Partial @code{python-black} formatting")
(description
- "This package is built on top the @{python-black} code formatter to
+ "This package is built on top the @code{python-black} code formatter to
enable formatting of partial files.")
(license license:bsd-3)))
@@ -17028,7 +17028,7 @@ (define-public python-pysendfile
(invoke "make" "test")))))))
(home-page "https://github.com/giampaolo/pysendfile")
(synopsis "Python interface to sendfile(2)")
- (description "The @{pysendfile} Python library provides an interface to
+ (description "The @code{pysendfile} Python library provides an interface to
the @code{sendfile(2)} system call.")
(license license:expat)))
@@ -1263,7 +1263,7 @@ (define-public qt5compat
(description "The @code{qt5compat} package includes application
programming interfaces (APIs) from Qt 5 that were ported to Qt 6, to ease
migration. It provides for example the @code{GraphicalEffects} module that
-came with the @{qtgraphicaleffects} Qt 5 package.")
+came with the @code{qtgraphicaleffects} Qt 5 package.")
(license (list license:gpl2+ license:lgpl3+)))) ;dual licensed
(define-public qtsvg-5
@@ -11239,7 +11239,7 @@ (define-public ruby-ruby-engine
(description
"@code{ruby_engine} provides an RubyEngine class that can be used to
check which implementation of Ruby is in use. It can provide the interpreter
-name and provides query methods such as @{RubyEngine.mri?}.")
+name and provides query methods such as @code{RubyEngine.mri?}.")
(home-page "https://github.com/janlelis/ruby_engine")
(license license:expat)))
@@ -12153,7 +12153,7 @@ (define-public ruby-httpclient
"Make HTTP requests with support for HTTPS, Cookies, authentication and more")
(description
"The @code{httpclient} ruby library provides functionality related to
-HTTP. Compared to the @code{net/http} library, @{httpclient} also provides
+HTTP. Compared to the @code{net/http} library, @code{httpclient} also provides
Cookie, multithreading and authentication (digest, NTLM) support.
Also provided is a @command{httpclient} command, which can perform HTTP
@@ -253,7 +253,7 @@ (define-public python-memory-allocator
(home-page "https://github.com/sagemath/memory_allocator")
(synopsis "Extension class to allocate memory easily with Cython")
(description "This package provides a single extension class
- @code{MemoryAllocator} with @{cdef} methods
+ @code{MemoryAllocator} with @code{cdef} methods
@itemize
@item @code{malloc}
@@ -92,7 +92,7 @@ (define-public sc-im
(synopsis "Spreadsheet program with vim-like keybindings")
(description
"@code{sc-im} is a highly configurable spreadsheet program
- providing a vim-like experience. @code{sc-im} supports @{gnuplot} interaction,
+ providing a vim-like experience. @code{sc-im} supports @code{gnuplot} interaction,
functions for sorting and filtering, 256 color support, and much more.")
(license bsd-4)))
@@ -325,7 +325,7 @@ (define-public python-pendulum
(home-page "https://github.com/sdispater/pendulum")
(synopsis "Alternate API for Python datetimes")
(description "Pendulum is a drop-in replacement for the standard
-@{datetime} class, providing an alternative API. As it inherits from the
+@code{datetime} class, providing an alternative API. As it inherits from the
standard @code{datetime} all @code{datetime} instances can be replaced by
Pendulum instances.")
(license expat)))