diff mbox series

[bug#36213,2/4] gnu: Add python-pyroute2, python2-pyroute2.

Message ID 45b0bac5-1b53-4939-a1b8-effd0ea0c6fb@www.fastmail.com
State Accepted
Headers show
Series Add pulseaudio-dlna | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin June 14, 2019, 7:23 p.m. UTC
attached
diff mbox series

Patch

From 427cfc454cba81de55985eb39dde83ab30b8c7f9 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Thu, 13 Jun 2019 15:46:10 -0500
Subject: [PATCH 2/4] gnu: Add python-pyroute2, python2-pyroute2.

* gnu/packages/python-xyz.scm (python-pyroute2): New variable.
(python2-pyroute2): New variable.

fixup pyroute2
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e07f9532ed..cceddf8f3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6650,6 +6650,42 @@  and MAC network addresses.")
 (define-public python2-netaddr
   (package-with-python2 python-netaddr))
 
+(define-public python-pyroute2
+  (package
+    (name "python-pyroute2")
+    (version "0.5.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyroute2" version))
+       (sha256
+        (base32
+         "1gmz4r1w0yzj6fjjypnalmfyy0lnfznydyn62gi3wk50j5hhxbny"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/svinota/pyroute2")
+    (synopsis "Python netlink library")
+    (description
+     "Pyroute2 is a pure Python netlink library with minimal dependencies.
+Supported netlink families and protocols include:
+@itemize
+@item rtnl, network settings - addresses, routes, traffic controls
+@item nfnetlink - netfilter API: ipset, nftables, ...
+@item ipq - simplest userspace packet filtering, iptables QUEUE target
+@item devlink - manage and monitor devlink-enabled hardware
+@item generic - generic netlink families
+  @itemize
+  @item nl80211 - wireless functions API (basic support)
+  @item taskstats - extended process statistics
+  @item acpi_events - ACPI events monitoring
+  @item thermal_events - thermal events monitoring
+  @item VFS_DQUOT - disk quota events monitoring
+  @end itemize
+@end itemize")
+    (license license:gpl2+)))
+
+(define-public python2-pyroute2
+  (package-with-python2 python-pyroute2))
+
 (define-public python-wrapt
   (package
     (name "python-wrapt")
-- 
2.22.0