[bug#67793,v2] gnu: Add exprtk.
Commit Message
* gnu/packages/maths.scm (exprtk): New variable.
Change-Id: I25e5a37cfd72b4b47dedc36916781b6ac355501e
---
gnu/packages/maths.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
Comments
Dear Futurile,
yes, copying exprtk.hpp only is intended. It contains the full (header-only) library. The license file is also copied into the store package.
Sincerely,
Lars
@@ -10826,3 +10826,23 @@ (define-public lie
(home-page "http://www-math.univ-poitiers.fr/~maavl/LiE/")
;; <http://www-math.univ-poitiers.fr/~maavl/LiE/> says LGPL.
(license license:lgpl3+)))
+
+(define-public exprtk
+ (package
+ (name "exprtk")
+ (home-page "https://www.partow.net/programming/exprtk/index.html")
+ (synopsis "C++ Mathematical Expression Parsing And Evaluation Library")
+ (description "A C++ library for mathematical expression parsing and evaluation")
+ (license license:expat)
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArashPartow/exprtk")
+ (commit version)))
+ (sha256
+ (base32 "0pszh11w29nc256qhil51g3635n06ncf0ihg7g4h86jrhqsk7183"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("exprtk.hpp" "include/"))))))