diff mbox series

[bug#38127] gnu: Add x42-plugins.

Message ID 452ecadc3842a20e4e6c768649855525@posteo.net
State Accepted
Headers show
Series [bug#38127] gnu: Add x42-plugins. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 10:55 a.m. UTC
NOTE: this patch depends on
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121 and
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38126

 From ee2e983068b3dd11aaed7c703388904749e77a44 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:54:00 +0000
Subject: [PATCH] gnu: Add x42-plugins.

* gnu/packages/music.scm: (x42-plugins): New variable.
---
  gnu/packages/music.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 55 insertions(+)

+audio and MIDI plugins that can also run as standalone JACK 
applications.")
+    (home-page "https://x42-plugins.com/x42/")
+    (license license:gpl2+)))

Comments

Marius Bakke Nov. 10, 2019, 10 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> NOTE: this patch depends on
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121 and
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38126
>  From ee2e983068b3dd11aaed7c703388904749e77a44 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:54:00 +0000
> Subject: [PATCH] gnu: Add x42-plugins.
>
> * gnu/packages/music.scm: (x42-plugins): New variable.

The patch LGTM overall, but indentation seems to be off.  Can you run
this through "./etc/indent-code.el"?

[...]

> +    (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
> +    (description "x42-plugins is a collection of over 80 cross-platform 
> LV2
> +audio and MIDI plugins that can also run as standalone JACK 
> applications.")
> +    (home-page "https://x42-plugins.com/x42/")
> +    (license license:gpl2+)))

I notice in the FAQ that "Some binaries are provided as demo.  A
license/signature file is required to remove the evaluation
restrictions".

If there are such binaries in the source tarball, they must be removed
with a source 'snippet' to ensure 'guix build --source' contains only
free software.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..a6caf4d0ff 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,57 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public x42-plugins
+  (package
+    (name "x42-plugins")
+    (version "20191013")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "http://gareus.org/misc/x42-plugins/x42-plugins-"
+               version ".tar.xz"))
+        (sha256
+          (base32
+            "18kn1bmc0s6dp834kc51ibifzzn3bxwya4p8s8yq9f4mpmkghi24"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "LIBZITACONVOLVER=-lzita-convolver"
+             (string-append
+              "FONTFILE=" (assoc-ref %build-inputs "font-dejavu")
+              "/share/fonts/truetype/DejaVuSans-Bold.ttf"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _ (setenv "CC" "gcc") #t))
+         (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("fftwf" ,fftwf)
+       ("jack" ,jack-1)
+       ("fftw" ,fftw)
+       ("ftgl" ,ftgl)
+       ("glib" ,glib)
+       ("glibc" ,glibc)
+       ("glu" ,glu)
+       ("hicolor-icon-theme" ,hicolor-icon-theme)
+       ("libsamplerate" ,libsamplerate)
+       ("libx11" ,libx11)
+       ("libltc" ,libltc)
+       ("pango" ,pango)
+       ("zita-convolver" ,zita-convolver)))
+    (native-inputs
+     `(("help2man" ,help2man)
+       ("liblo" ,liblo)
+       ("lv2" ,lv2)
+       ("font-dejavu" ,font-dejavu)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
+    (description "x42-plugins is a collection of over 80 cross-platform 
LV2