[bug#34515,10/13] gnu: Add python-autobahn.

Message ID 44e542e83121ab7fe02f134d349fbb484396ce30.1550437064.git.leo@famulari.name
State Accepted
Headers show
Series [bug#34515,01/13] gnu: Add python-humanize. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Leo Famulari Feb. 17, 2019, 8:57 p.m. UTC
* gnu/packages/python-web.scm (python-autobahn): New variable.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ricardo Wurmus Feb. 18, 2019, 8:27 a.m. UTC | #1
Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/python-web.scm (python-autobahn): New variable.
[…]
> +    (arguments
> +     `(#:tests? #f)) ; fail mysteriously

Mysteriously, eh?  Do you have any more information about this that
might help us debug this?

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e54f09ddb4..b2b6daee51 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -56,6 +56,7 @@ 
   #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages django)
+  #:use-module (gnu packages libffi)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
@@ -3000,3 +3001,30 @@  correct URLs for Python according to RFCs 3986 and 3987.")
 @code{requests}} but written on top of @code{Twisted's} Agents.  It offers a
 high level API for making HTTP requests when using Twisted.")
     (license license:expat)))
+
+(define-public python-autobahn
+  (package
+    (name "python-autobahn")
+    (version "19.2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "autobahn" version))
+        (sha256
+         (base32
+          "1mm7j24ls01c7jb1ad5p5cpyxvzgydiyf8b04ihykh2v8g98j0x7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; fail mysteriously
+    (propagated-inputs
+     `(("python-cffi" ,python-cffi)
+       ("python-twisted" ,python-twisted)
+       ("python-txaio" ,python-txaio)))
+    (home-page "https://crossbar.io/autobahn/")
+    (synopsis "Web Application Messaging Protocol implementation")
+    (description "This package provides an implementation of the @dfn{Web Application
+Messaging Protocol} (WAMP).  WAMP connects components in distributed
+applications using Publish and Subscribe (PubSub) and routed Remote Procedure
+Calls (rRPC).  It is ideal for distributed, multi-client and server applications
+such as IoT applications or multi-user database-driven business applications.")
+    (license license:expat)))