diff mbox series

[bug#65751,1/2] gnu: emacs-transient: Update to 0.4.3-0.cc0fa80.

Message ID 44e2772f5061d9991c79f7f1361eac462b0424a7.1693887006.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Update emacs-magit to 3.3.0-5.186414a. | expand

Commit Message

Maxim Cournoyer Sept. 5, 2023, 4:10 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-transient): Update to 0.4.3-0.cc0fa80.
---

 gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
 1 file changed, 37 insertions(+), 33 deletions(-)


base-commit: bf231a591c874dd7af57923f0b513823d1e0d6d2
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 802cf1ccaa..c3652c703c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30150,43 +30150,47 @@  (define-public emacs-elmacro
     (license license:gpl3+)))
 
 (define-public emacs-transient
-  (package
-    (name "emacs-transient")
-    (version "0.4.3")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/magit/transient")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "03qs1bj7dxgdppzcnhzmldpdam1h8kzd0ps2bk82slypm7d63nay"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:tests? #f                      ;no test suite
-       #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'build-info-manual
-                    (lambda _
-                      (invoke "make" "info")
-                      ;; Move the info file to lisp so that it gets
-                      ;; installed by the emacs-build-system.
-                      (rename-file "docs/transient.info"
-                                   "lisp/transient.info")))
-                  (add-after 'build-info-manual 'enter-lisp-directory
-                    (lambda _
-                      (chdir "lisp"))))))
-    (native-inputs (list texinfo))
-    (propagated-inputs (list emacs-compat))
-    (home-page "https://magit.vc/manual/transient")
-    (synopsis "Transient commands in Emacs")
-    (description
-     "Taking inspiration from prefix keys and prefix arguments
+  ;; Use this unreleased commit to support a recent Magit change needed to add
+  ;; Reviewed-by: tags for any contributor.
+  (let ((commit "cc0fa80530b02493f73b870032bfcdd1435286cd")
+        (revision "0"))
+    (package
+      (name "emacs-transient")
+      (version (git-version "0.4.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/magit/transient")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10yaanpz3krh3f9vzyafg6n85yp8sk58gj9vrpsqg926x4m0w1p1"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:tests? #f                      ;no test suite
+         #:phases (modify-phases %standard-phases
+                    (add-after 'unpack 'build-info-manual
+                      (lambda _
+                        (invoke "make" "info")
+                        ;; Move the info file to lisp so that it gets
+                        ;; installed by the emacs-build-system.
+                        (rename-file "docs/transient.info"
+                                     "lisp/transient.info")))
+                    (add-after 'build-info-manual 'enter-lisp-directory
+                      (lambda _
+                        (chdir "lisp"))))))
+      (native-inputs (list texinfo))
+      (propagated-inputs (list emacs-compat))
+      (home-page "https://magit.vc/manual/transient")
+      (synopsis "Transient commands in Emacs")
+      (description
+       "Taking inspiration from prefix keys and prefix arguments
 in Emacs, Transient implements a similar abstraction involving a prefix
 command, infix arguments and suffix commands.  We could call this abstraction
 a \"transient command\", but because it always involves at least two
 commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-forge
   (package