diff mbox series

[bug#63903,10/11] gnu: Add go-github-com-rylans-getlang.

Message ID 44d931d3e225566a12fd608d537e6f0ae85cfbde.1685958854.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add miniflux. | expand

Commit Message

Hilton Chain June 5, 2023, 10:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-rylans-getlang): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 10c2e46670..7dca1ebfbc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13038,6 +13038,32 @@  (define-public go-github-com-riywo-loginshell
 of the current user.")
     (license license:expat)))
 
+(define-public go-github-com-rylans-getlang
+  (package
+    (name "go-github-com-rylans-getlang")
+    (version "0.0.0-20201227074721-9e7f44ff8aa0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rylans/getlang")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yf698h21j88d7d9wkzq69cfd7vs1mfp96nhb83lx6hhh7rfvb92"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/rylans/getlang"))
+    (propagated-inputs
+     (list go-golang-org-x-text))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/rylans/getlang")
+    (synopsis "Natural language detection package in pure Go")
+    (description
+     "This package provides fast natural language detection in Go.")
+    (license license:expat)))
+
 (define-public go-github-com-kyoh86-xdg
   (package
     (name "go-github-com-kyoh86-xdg")