diff mbox series

[bug#41169] gnu: xfe: Fix few more FHS directories.

Message ID 44a01b5d-48bf-7c25-411f-9aab905cde4a@disroot.org
State Accepted
Headers show
Series [bug#41169] gnu: xfe: Fix few more FHS directories. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan May 10, 2020, 8:58 a.m. UTC

Comments

Raghav Gururajan May 11, 2020, 5:40 a.m. UTC | #1
Hi Nicolas!

Regarding the previous xfe patch, it looks like there are couple more
things to be patched. I have generated this patch for that. Would you be
able to push it please?

Thank you!

Regards,
RG.
Nicolas Goaziou May 11, 2020, 6:54 a.m. UTC | #2
Hello,

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> From 585adef1a8f0fdf510bf0597b943eb8b610a0f76 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sun, 10 May 2020 04:49:25 -0400
> Subject: [PATCH] gnu: xfe: Fix few more FHS directories.

Applied. Thank you.

Regards,
Raghav Gururajan May 11, 2020, 6:55 a.m. UTC | #3
Hi Nicolas!

> Applied. Thank you.

Thanks so much.

Regards,
RG.
diff mbox series

Patch

From 585adef1a8f0fdf510bf0597b943eb8b610a0f76 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 10 May 2020 04:49:25 -0400
Subject: [PATCH] gnu: xfe: Fix few more FHS directories.

* gnu/packages/disk.scm (xfe): Fix /bin and /share paths in
st/config.h and src/xfedefs.h, respectively.
---
 gnu/packages/disk.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 0e35ef7de1..15f08773f8 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -990,7 +990,8 @@  since they are better handled by external tools.")
                     (file-prog (assoc-ref inputs "file")))
                (with-directory-excursion "src"
                  (substitute* '("FilePanel.cpp" "help.h" "SearchPanel.cpp"
-                                "startupnotification.cpp" "xfeutils.cpp")
+                                "startupnotification.cpp" "xfeutils.cpp"
+                                "../st/config.h")
                    (("/bin/sh" file) (string-append bash file))
                    (("/bin/ls" file) (string-append coreutils file))
                    (("/usr(/bin/du)" _ file) (string-append coreutils file))
@@ -1002,11 +1003,13 @@  since they are better handled by external tools.")
          (add-after 'unpack 'patch-share-dirs
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
-                    (share (string-append out "/share")))
+                    (share (string-append out "/share"))
+                    (xfe (string-append share "/xfe")))
                (with-directory-excursion "src"
                  (substitute* '("foxhacks.cpp" "help.h" "xfedefs.h"
                                 "XFileExplorer.cpp")
-                   (("/(usr|opt)(/local)?/share") share)))
+                   (("/(usr|opt)(/local)?/share") share)
+                   (("~/.config/xfe") xfe)))
                #t))))))
     (native-inputs
      `(("intltool" ,intltool)
-- 
2.26.2