From 585adef1a8f0fdf510bf0597b943eb8b610a0f76 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 10 May 2020 04:49:25 -0400
Subject: [PATCH] gnu: xfe: Fix few more FHS directories.
* gnu/packages/disk.scm (xfe): Fix /bin and /share paths in
st/config.h and src/xfedefs.h, respectively.
---
gnu/packages/disk.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
@@ -990,7 +990,8 @@ since they are better handled by external tools.")
(file-prog (assoc-ref inputs "file")))
(with-directory-excursion "src"
(substitute* '("FilePanel.cpp" "help.h" "SearchPanel.cpp"
- "startupnotification.cpp" "xfeutils.cpp")
+ "startupnotification.cpp" "xfeutils.cpp"
+ "../st/config.h")
(("/bin/sh" file) (string-append bash file))
(("/bin/ls" file) (string-append coreutils file))
(("/usr(/bin/du)" _ file) (string-append coreutils file))
@@ -1002,11 +1003,13 @@ since they are better handled by external tools.")
(add-after 'unpack 'patch-share-dirs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share")))
+ (share (string-append out "/share"))
+ (xfe (string-append share "/xfe")))
(with-directory-excursion "src"
(substitute* '("foxhacks.cpp" "help.h" "xfedefs.h"
"XFileExplorer.cpp")
- (("/(usr|opt)(/local)?/share") share)))
+ (("/(usr|opt)(/local)?/share") share)
+ (("~/.config/xfe") xfe)))
#t))))))
(native-inputs
`(("intltool" ,intltool)
--
2.26.2