diff mbox series

[bug#71968,v2,3/5] gnu: fastfetch: Add more configure flags.

Message ID 446b9098aa7f012c68629ca27b8d9435134ae953.1720942674.git.dariqq@posteo.net
State New
Headers show
Series fastfetch: Unbundle yyjson and package improvements | expand

Commit Message

Dariqq July 14, 2024, 7:42 a.m. UTC
Most importantly the dependencies are now linked dynamically to avoid writing out a
LD_LIBRARY_PATH wrapper.

Also build the tests and skip installing the license file.

Additionally provide custom paths to pci-ids and amdgpu-ids.

* gnu/packages/admin.scm (fastfetch)
(arguments): Move above inputs.
[#:configure-flags]: Add -DBUILD_TESTS=ON, -DINSTALL_LICENSE=OFF,
-DBINARY_LINK_TYPE=dynamic and set -DCUSTOM_PCI_IDS_PATH and
-DCUSTOM_AMDGPU_IDS_PATH.
[#:tests]: Remove as now there are tests available.
[inputs]: Add hwdata and libdrm for the custom paths.

Change-Id: I9f86b49f0a116bcee91ca15b6e77cfbb3867e290
---
 gnu/packages/admin.scm | 17 ++++++++++++++---
 1 file changed, 14 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a9651b49d0..e97fe76a5a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4280,18 +4280,29 @@  (define-public fastfetch
        (snippet '(begin
                    (delete-file-recursively "src/3rdparty")))))
     (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=YES"
+                                "-DBINARY_LINK_TYPE=dynamic"
+                                "-DBUILD_TESTS=ON"
+                                "-DINSTALL_LICENSE=OFF"
+                                (string-append "-DCUSTOM_PCI_IDS_PATH="
+                                               #$(this-package-input "hwdata")
+                                               "/share/hwdata/pci.ids")
+                                (string-append "-DCUSTOM_AMDGPU_IDS_PATH="
+                                               #$(this-package-input "libdrm")
+                                               "share/libdrm/amdgpu.ids"))))
     (inputs (list dbus
                   glib
+                  hwdata
                   imagemagick
+                  libdrm
                   libxcb
                   mesa
                   wayland
                   yyjson
                   zlib)) ;for imagemagick and an #ifdef
     (native-inputs (list pkg-config))
-    (arguments
-     (list #:tests? #f                  ; no test target
-           #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=YES")))
     (home-page "https://github.com/fastfetch-cli/fastfetch")
     (synopsis "Display system information in a stylized manner")
     (description