[bug#76572,v2,4/4] gnu: gnome-shell-extension-gsconnect: Fix paths in additional desktop file.
Commit Message
This fixes the gsconnect preferences button ("Mobile Settings") in the
top-right quick-access menu not opening the preferences application. The
window icon also displays properly with this commit.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect):
[arguments]<#:phases>: Patch gapplication path in an additional desktop file
in 'fix-paths phase.
Change-Id: I6b84474e4976484f1203b7cf78fe5e882694cd22
---
gnu/packages/gnome-xyz.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
@@ -778,8 +778,12 @@ (define-public gnome-shell-extension-gsconnect
(lambda* (#:key inputs #:allow-other-keys)
(let ((gapplication (search-input-file inputs "/bin/gapplication"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (substitute* "data/org.gnome.Shell.Extensions.GSConnect.desktop.in"
- (("gapplication") gapplication))
+ (for-each
+ (lambda (file)
+ (substitute* file
+ (("gapplication") gapplication)))
+ '("data/org.gnome.Shell.Extensions.GSConnect.desktop.in"
+ "data/org.gnome.Shell.Extensions.GSConnect.Preferences.desktop.in"))
(for-each (lambda (file)
(with-atomic-file-replacement
file