[bug#77371,03/12] gnu: Add python-boost-histogram.
Commit Message
* gnu/packages/python-science.scm (python-boost-histogram): New variable.
Change-Id: I91e73a0a3e3a698197b2d309bd5bdf388fd2697a
---
gnu/packages/python-science.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
@@ -816,6 +816,33 @@ (define-public python-scikit-misc
and scientific computing.")
(license license:bsd-3)))
+(define-public python-boost-histogram
+ (package
+ (name "python-boost-histogram")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boost_histogram" version))
+ (sha256
+ (base32 "0p2f90p5jwlwrjz3hq2fzaifkmny33g2mpi89nnhi3w41f1jxr2i"))))
+ (build-system pyproject-build-system)
+ ;; This package bundles files from Boost::Histogram and doesn't provide
+ ;; a way to use a system library.
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list cmake-minimal
+ pybind11-2.13
+ python-pytest
+ python-pytest-benchmark
+ python-scikit-build-core
+ python-setuptools-scm))
+ (home-page "https://boost-histogram.readthedocs.io/en/latest/")
+ (synopsis "Python bindings for the Boost::Histogram library")
+ (description
+ "This package provides Python bindings for the Boost::Histogram library,
+one of the fastest libraries for histogramming.")
+ (license license:bsd-3)))
+
(define-public python-scikit-opt
(package
(name "python-scikit-opt")