diff mbox series

[bug#38117] gnu: Add helm.

Message ID 443a28734ac5866ea443b9cd7366d65a@posteo.net
State Accepted
Headers show
Series [bug#38117] gnu: Add helm. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 9:30 a.m. UTC
From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:25:08 +0000
Subject: [PATCH] gnu: Add helm.

* gnu/packages/music.scm: (helm): New variable.
---
  gnu/packages/music.scm | 54 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 54 insertions(+)

+    (description "Helm is a cross-platform polyphonic synthesizer 
available standalone
+and as an LV2 plugin.")
+    (license license:gpl3+)))

Comments

Marius Bakke Nov. 10, 2019, 10:29 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

>  From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:25:08 +0000
> Subject: [PATCH] gnu: Add helm.
>
> * gnu/packages/music.scm: (helm): New variable.

LGTM.
Ludovic Courtès Nov. 18, 2019, 11:16 a.m. UTC | #2
Hello,

Alexandros Theodotou <alex@zrythm.org> skribis:

> From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:25:08 +0000
> Subject: [PATCH] gnu: Add helm.
>
> * gnu/packages/music.scm: (helm): New variable.

I applied it but it fails for me at the end:

--8<---------------cut here---------------start------------->8---
starting phase `reset-gzip-timestamps'
Backtrace:
           9 (primitive-load "/gnu/store/qaparaqbwqw4v0hwfd50s37mikz…")
In ice-9/eval.scm:
   191:35  8 (_ _)
In ice-9/boot-9.scm:
    829:9  7 (catch _ _ #<procedure 7ffff5bc0518 at /gnu/store/w3jl…> …)
In srfi/srfi-1.scm:
   863:16  6 (every1 #<procedure 7ffff4c111e0 at /gnu/store/w3jlc8p…> …)
In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-import/guix/build/gnu-build-system.scm:
   839:30  5 (_ _)
    594:5  4 (reset-gzip-timestamps #:outputs _)
In srfi/srfi-1.scm:
    640:9  3 (for-each #<procedure process-directory (directory)> (#))
    640:9  2 (for-each #<procedure reset-gzip-timestamp (file #:key…> …)
In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-import/guix/build/utils.scm:
   262:14  1 (reset-gzip-timestamp "/gnu/store/04j1kvzkx8n5ldbcbckh…" …)
In unknown file:
           0 (open "/gnu/store/04j1kvzkx8n5ldbcbckhcmbw4n3vzrwz-hel…" …)

ERROR: In procedure open:
In procedure open-fdes: Permission denied
builder for `/gnu/store/xj20qjw2mgp2yc59hmafmkgg780n1ci7-helm-0.9.0.drv' failed with exit code 1
--8<---------------cut here---------------end--------------->8---

Could you take a look?

As an aside, the patch had been mangled on its way.  Could you send it
as an attachment or with ‘git send-email’ next time?

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..cf883d034f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,56 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public helm
+  (package
+    (name "helm")
+    (version "0.9.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/mtytel/helm.git")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+             "lv2" "standalone")
+       #:phases
+       (modify-phases
+        %standard-phases
+        (add-after 'unpack 
'include-pnglib-code-and-remove-usr-from-paths
+           (lambda _
+             (substitute* "standalone/builds/linux/Makefile"
+                          (("JUCE_INCLUDE_PNGLIB_CODE=0")
+                           "JUCE_INCLUDE_PNGLIB_CODE=1"))
+             (substitute* "builds/linux/LV2/Makefile"
+                          (("JUCE_INCLUDE_PNGLIB_CODE=0")
+                           "JUCE_INCLUDE_PNGLIB_CODE=1"))
+             (substitute* "Makefile" (("/usr") ""))
+             #t))
+        (delete 'configure))))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("curl" ,curl)
+       ("freetype2" ,freetype)
+       ("hicolor-icon-theme" ,hicolor-icon-theme)
+       ("libxcursor" ,libxcursor)
+       ("libxinerama", libxinerama)
+       ("jack", jack-1)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lv2", lv2)))
+    (home-page "https://tytel.org/helm/")
+    (synopsis "Polyphonic synth with lots of modulation")